Video Screencast Help

Enterprise Vault Databases unavailable for selection after Agent Backup

Created: 09 Jan 2013 • Updated: 11 Jan 2013 | 1 comment
Simon B.'s picture
This issue has been solved. See solution.
Hello forum,
we have a case where the BE Agent for Enterprise Vault (BE 2012) was tested for evaluation purposes in the past but it was decided to switch back to normal script based backups (where the SQL Database would be backed up normally through the BE SQL Agent).
The issue is that even after uninstalling the RAWS from the EV Server and removing the "Directory on ..."-Entry from the serverlist the EV databases are still grayed out when creating a new backup job. All other Databases on the same SQL Server are available for selection so the issue is only with the EV databases - presumably because BE still things they are backed up via the EV agent.
The EV Agent itself cannot be removed from the installed options on the BE server  (like in erlier version) as it is now included in the "Agent for Applications and Databases"-Option.
We even removed the entries from the NRDSAgent-Table - the checkboxes for these databases remain grayed out though.
Any ideas on how make them selectable again?

Comments 1 CommentJump to latest comment

Simon B.'s picture

We have found a solution for this problem. For anyone coming here searching for a way to solve this issue:

  • Stop the RAWS on the SQL Server
  • Open Regedit on the SQL Server
  • Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\EV Agent
  • You will see a Value on the right side named similar to your SQL Server/EV Site or SQL Instance. Hex encoded in the Value Data you will find a list of databases which are recognized as EV Databases
  • Make a Backup of this Registry Key
  • Delete the Value
  • Start the RAWS

The Databases should be available for selections again.

PMCS GmbH & Co. KG - Consulting und Support für BE/NBU/EV und andere Symantec Produkte.
Please take the time and mark this post as solution if it solved your problem - thanks!