Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

enterprise vault, emails in archiving pending state after dag failover during archiving process

Created: 05 Jul 2013 | 10 comments

hi

last week during our weekly archiving processes (we run archiving once per week between 7 and 11pm on Thursdays) our exchange 2010 mailbox server encountered some issues which resulted in the some of the mailbox databases activating on other DAG members (they switched a couple of times back and forth over a 6 hour period)

when i noticed this in the morning in my mailbox i now have 49 items in the pending archive state. so it looks like they have been archived but somehow they are not converting into archived items after the enterprise vault server (v10sp3) has been backed up. Last nights archive job ran fine and all items that were archived last night are showing as archived items, but no the 49 items from the previous run last week

i have not checked all the mailboxes but is there a way to a) get these pending archived items converted into archived items and b) to run a report to see how many items are in this state. we have about 25 email archives (mailboxes) and i have been able to check 2 others by using a search folder in outlook on their mailbox but i can hardly do this on all 25 mailboxes)

many thanks

Operating Systems:

Comments 10 CommentsJump to latest comment

elbutre's picture

i checked both technotes

the items are in the archive (i can find them with a search) and backups have taken place and the queues are empty

i also move the mbx database back to the mailbox server where it is supposed to be active but this did not help, i still have 47 pending archiving messages in my outlook

in technote 66202 i ran the 2 sql commands and both ressults were empty so there is nothing awaiting backup.

so it seems that all the emails have been archived, backed up and the vast majority have had their message class changed to enterprise vault, but some mailboxes (at least mine) still have the pending archive messages.

it is not clear from these 2 technotes how i should recover from this

the best safest way seems to be to find all the pending archiving messages in a mailbox and select cancel operation and let the items archive again although i will end up with duplicates but better to have 47 duplicates than not having the incorrect form associated with it

i will try finding a powershell command to see which items have the pending archiving messageclass on the exchange server and manually check those mailboxes, i reckon it will be about 10 mailboxes in total

John Santana's picture

ok, so based on this case, should we also stop EV or at least restart EV Admin service when the Exchange server CCR mailbox is fail over or Exchange Server 2010/2013 activated in the other node ?

Kind regards,

John Santana
IT Professional

--------------------------------------------------

Please be nice to me as I'm newbie in this forum.

Rounk's picture

I am experiencing the same issue on our system and have not been able to find a solution. Have you made any progress with this? We have around 248 mailboxes that are experiencing the issue and I really don't want to touch each mailbox. Symantec support has been not been close to being helpful.....very frustrating!

elbutre's picture

i went in to each mailbox (25 instead of 248) and did this manually (unfortunately)

it has never happened again since though.

i did not know about the shortcut timeout although would that apply to already processed emails as well or only from the date you made the shortcut expiry change?

JesusWept3's picture

i would just set the shortcut timeout to 3 days, and let it naturally reset the items
when it goes back, it will notice the items have already been archived and post process them, as long as the backups have definitely taken place and theres nothing awaiting to be secured

That being said, the server that it failed over to, is the task on the same EV Server or another EV server?
It's possible that the items are simply stuck in the Outoging Queues from one EV Server to another

Rounk's picture

We aren't 100% sure what happened that caused the issue. It could have happened when we reduced the Age Based (Archive items when they are older than:) setting to 3 months or when we migrated the servers from Windows 2003 to Windows 2008 (and updated the software from EV8 to EV10). We just happened to notice that there was a small window of emails that were stuck in archive pending state.

We have already changed the "Pending shortcut timeout" to 0 and restarted all services and refreshed all tasks. This did not correct the issue.

JesusWept3's picture

Setting to 0 will make no difference unless you run in report mode

And pending shortcut timeout just means any items in a pending state will be reverted to a normal message after X amount of days

Then when archiving runs again and processes the item will see it's already archived and turn it into a shortcut

Rounk's picture

Ok, I will set the the pending shortcut time to 2 and wait till Monday to see if it corrects the archiving pending messages.

Rounk's picture

Changing the pending shortcut timeout to 2 on Friday did not make any difference. Mailboxes still contained "pendingarchive" items. We have manually gone through the mailboxes and cleaned them up since we haven't been able to find a valid solution. Thanks for everyone's help!