Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Enterprise Vault: File System task Enabled but orginal file were not moved to Archive Storage during archive.

Created: 28 Jan 2013 • Updated: 04 Feb 2013 | 21 comments
This issue has been solved. See solution.

Hi there,

I am a newbie to Symantec Enterprise Vault and I apologize if my question has been asked before, though i could not find a solution to my problem on this forum.

I am working with Sym. Enter. Vault 10.0.1.  The Vault server has been successfully installed and configured [To my knowledge] I have two different file servers connect to it and FSA installed.  As you can see from the screenshot below the task is running and is able to identify files that matches the archive rule.

To keep things simple, I am trying to archive all files created or accessed before 2010.  Below are my criteria on Volume and folder level.

No Attributes

For some reason, nothing happens after the processing. It barely archives anything [maybe about 5 % of the total archive files].  All files identified as ready for archive were not removed from their original location [file servers], they remained with their original size!

After the "archive" I noticed that all folders and files Attributes are Read-Only and Hidden, though the users are able to access files without problems. And again, the folder and files size remains the same from the original location.

What am i doing wrong?  I lowered the criteria to only files access time [3 or 4 years] without success.

Your urgent response would be hugely appreciated.


Comments 21 CommentsJump to latest comment

JesusWept3's picture

And are you using after backup?
And are you doing anything like archive now shortcut later?

How are you determining what is getting archived vs what isn't?

katunar's picture


I appreciate very much your quick replies.

Here is the summary of my report

from the 1st files server:


Second File server

Also I have these two:

First it runs and i have something like this on all folders: 

Then the below

To answer your question:

1. I guess I am using after backup! though I have not much knowledge on that!

2. I am using shortcut immediately.

3. to determine what is being archived on not, i go back to the original folders to check when the file was created, accessed and modified.  I can clearly see that they were not moved. and the summary above seems to confirm my suspicions.

Rob.Wilcox's picture

You'll need to take a read-up on how to do Enterprise Vault backups, and you'll then be all set.. the items will get converted in to placeholders.

Until that happens items are still being archived, but you won't see any space savings and so on until the backup side is sorted out.

katunar's picture

Thanks again for the prompt replies, I will report back once I have all setup and if my "issue" has been solved.

katunar's picture

Backup configured and performed as show below.

While I am still investigating on why the maintenance clean up fails, I tried to run the task and same results!  No shortcut creation and no files were moved from the original storage to Vault Storage.


Before running the archive tasks do I have to disable the backup mode on the vault stores? how about the index locations? From my understanding the two cannot go together!

Am I missing something? What am I doing wrong?

Rob.Wilcox's picture

If you run archiving with EV still in backup mode, then nothing will get archived.

The general rule of thumb is :-

* Do archiving run

* Allow a decent sized window to get a decent amount of stuff archived (that of course is open to debate!)

* Start backups by ..

*** Enter backup mode

*** Backup DB's, index volumes, and Vault Store Partition data

*** Exit backup mode

* NEXT archiving run those items which were archived, and secured (ie backed up) will then be turned in to shortcuts/placeholders along with data which will then be archived.

So you can see it's a two-run deal with FSA.

In my test, I created a file called testfile.txt with just some gibberish in it.

When I do an archiving run I see the same as you saw:


But remember the item HAS been archived.

When the task runs the first time you'll also see 'ARCHIVE' 'Archived'

When the task runs the next time after you've done a backup, you'll see 'ARCHIVE' 'ArchivedBackedUp', and then you'll see CREATESHORTCUTIMMEDIATELY followed by 'ShortcutCreated'.

Rememeber the thing you're backing up is the Vault Store partition data, not the target file server.

katunar's picture

I followed the steps above to backup my databases using SQL Database maintenance plan.

Once completed, I forced another Archive Task [Run now on Task]  and for some reasons when i check the report file, NO shortcut have been created, the files remain in the original location with original size.

Any idea of what I might be missing? I doubt it has to do with the Failing Maintenance Cleanup Task on the SQL server as the rest of Backup tasks on SQL are successful!

On another note, I am also planning to back Vault Store Partition separately with Netbackup 7.5 every other 3rd month.

What do you think?

Rob.Wilcox's picture

Please review my steps:

* Do archiving run

* Allow a decent sized window to get a decent amount of stuff archived (that of course is open to debate!)

* Start backups by ..

*** Enter backup mode

*** Backup DB's, index volumes, and Vault Store Partition data

*** Exit backup mode

* NEXT archiving run those items which were archived, and secured (ie backed up) will then be turned in to shortcuts/placeholders along with data which will then be archived.

If you want the item turned in to a placeholder/shortcut, then you HAVE TO backup up the Vault Store Partition Data.

IMHO every 3 months is too long.

You say you backed up SQL.  That's not enough to fulfill this process.

katunar's picture

Sorry for a dumb question: Is there a tool/utilities to back up the Vault Store partition within Enter. Vault or my NetBackup Backup Software suffice?
Unless I have the wrong manual it is not illustrated on how to back it up.

katunar's picture

OK, I think I found how to configure which method Enterprise Vault uses to ensure a partition’s data is
backed up.

Under Backup within the Vault Store Partition Properties, I selected the "Check for a trigger File" options. it was previously set to "Use the Archive Attribute".

Scheduled a NetBackup backup job. Let us see if this would solve my "issue"! :-)

Correct me if wrong! :-)

Rob.Wilcox's picture

So you set Backup Mode in Enterprise Vault (at the site level, at the vault store group level, or at the vault store level -- and at the index location level too).

Once you've done that then you can use 'any old backup software'.. Netbackup will do...  Windows Backup will do... pretty much 'anything'.

Then you come back out of backup mode.

Go to the video section, expand it to show 50 items, for EV, and then search on the page for backup...  or you can try this one of mine:

Rob.Wilcox's picture

You might be wrong.

Unless Netbackup creates the trigger file for you when the backup is complete.

Archive bit is 'fine'.

The other options are there for software / media that doesn't support the archive bit, or backup products that don't clear the archive bit.

katunar's picture

Awesome!  I will go through your video and follow your steps on backup/archiving.

Rob, Thanks again for your replies and help.

I keep you posted.

katunar's picture

Rob, I did everything again from scratch as per your instructions all is good!

Shortcuts are finally being created.  The task is still in process.

I am very much interest in how much space i would gain on my File Share server Storage's!

I also noticed while the files are being archived, there is an "X" on the file icon!  Could this has to do with permissions on files in my archive?

I am thinking to sync permissions once the archive task has been completed...

What say you?

Once again, i appreciate your help to get this up and running.

You are awesome.

TonySterling's picture

The X on the icon is just the how offline files disply:

File System Archiving placeholders show as an ' X' on Windows Vista or later version of Windows OS clients.

Article:TECH58322  |  Created: 2008-01-10  |  Updated: 2010-01-06  |  Article URL
Rob.Wilcox's picture

Yep.. Tony is true-to-the-mark. There is nothing to do here with those, it's just the way that Windows displays them.

katunar's picture

Funny I had just opened the same link on google :-)  Thanks Tony.

Question: would the users be able to open the files once i synch permissions? Or it is not necessary?

1. I have tried to copy one of the offline files to a workstation without success! "access denied"!

2. i have also try to open the files without success.  Access denied.

Is this a Microsoft problem? I have checked the security properties and users do have access.

katunar's picture

Problem solved with the huge help from Rob Wilcox.

My users are now able to access the achived files! :-)

These two articles help to solve my issue:

Rob, I appreciate a lot your replies and taking time to answer all my questions.
Thanks so much for your help getting my archive up and running.
You are awesome.