Video Screencast Help

Enterprise Vault - FSA Server - Deletion Issue.

Created: 12 Aug 2010 • Updated: 16 Apr 2014 | 4 comments
This issue has been solved. See solution.

Good afternoon all.

Currently, I have an simple File server running WIN2K3 whic is archived by an EV server v7.5.  A user deleted a folder on the file server which contained about 1GB of archived and non-archived files.  I have copied back the deleted folder from a replica server at another site, but the EV placeholders will not copy.  They only show as 0KB excel or word files.

 Now, when I browse using the archive explorer site, I am unable to see that deleted folder so I can restore the EV placeholders.  The vault is set to "not delete anything" so I am unsure as to why this has happened...

Does anyone have any idea what I need to do on this one?

Comments 4 CommentsJump to latest comment

TonySterling's picture

You could just use FSAUtility to recreate them.  You have moved servers but the technote below has the command to recreate the placeholders.

http://seer.entsupport.symantec.com/docs/329503.htm

How to move File System Archiving (FSA) to a new server with the same name

Details:

The following steps detail how to replace an existing FSA server with a new sever with the same name as the server that is being replaced:
 
  1. Backup the server that is being replaced via backup software that can backup "Offline" files (Placeholders). Not all Backup software can properly backup Placeholders, so the use of the FSAUtility to recreate Placeholders may be necessary. This process is begins at step 8
  2. Stop the FSA task on the Enterprise Vault (EV) Server.
  3. Replace the faulty server.
  4. Ensure the new server has the same name, IP address, Drive letters as the original server.
  5. Restore files to the new server (Folder structure should be re-created during the restore of the backup).
  6. Install the FSA agent on the new server.
  7. Restart the FSA task on the EV Server.
  8. If the backup software was not able to backup Offline Files then the main data on the File Server will need to be moved and then the Placeholders recreated. To do this continue to step 9 or refer to related Technote at bottom of this page under 'Related Documents".
  9. Open a command prompt and change directory to the EV install path. This is by default, c:\program files\Enterprise Vault
  10. Run the following command to recreate Placeholders:
 
                             FSAUtility -c -s \\unc_path_name\folder_name
 

Related Documents:

320911: How to move Placeholders from one Server to a new Server
 http://support.veritas.com/docs/320911

Paul O'Shaughnessy's picture

Thank you for your reply.

However, I only want to restore the placeholders on a sub folder within the File Server, not the entire file server.  Is their a way to do that?

Thanks again for your help,

Paul

Paul O'Shaughnessy's picture

OK - Sorry for the misunderstanding.  I ran the FSA utility to restore the original files back to their original location.  Please see output below.

FSA Data Mover Utility.
Symantec Enterprise Vault.
Copyright (c) 2006. Symantec Corporation.
Restore files
Folder      : \\server name\GCS_Dept\Dublin Shared\Administrative Repor
ts
Generating file list for processing...
Total restore job dispatch... 0%
Error: \\server name\GCS_Dept\Dublin Shared\Administrative Reports not
found.

C:\Program Files\Enterprise Vault>fsautility -t -s "\\server name\GCS_Dept\Dubl
in Shared\Administrative Reports"

Any ideas on what this error means?  Google and Symantec Forums dont return anything when searching....
 

TonySterling's picture

Are you running this as the VSA?

Also, can you check the server name in sql?
You can run this query:

Use EnterpriseVaultDirectory
Select * from FileServerEntry

Locate the entry in the DnsName field for the server listed and make sure it is not FQDN

SOLUTION