Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Enterprise Vault has stopped archiving/Outlook Addin doesn't work

Created: 12 Aug 2010 • Updated: 18 Nov 2010 | 13 comments

Hi All,

I will do my best to explain what I think is going on, but I have inherited since its original installation so I don't know all the ins and outs,

but we are still in the testing phase, before adding our company exchange users to it, so I want to make sure we can do everything properly first,

We have EV 8 SP1 installed, and I have got the hang of the Enterprise Vault MMC,

I have unarchived (using the "Export to PST" option) and disabled my account, and re-enabled my account and imported my PST, but it is now failing to auto archive my email, I think my boss has done a simalar thing, and his account has the same issue,

I have tried recreating all the shortcuts in EV, this hasn't fixed it,

Any ideas what I can try next?

Thanks

Simon
 

Comments 13 CommentsJump to latest comment

GertjanA's picture

Hello Simon,

what is your archiving policy?
If you import the pst in your inbox, and you have your policy to archive everything older than 30 days, it will take 30 days before EV starts archiving from your mailbox again. Due to the import, the date EV uses to decide what to archive changes.

You could do an archive run in report mode (ricghtclick task, run now, report mode, selected mailbox) on your mailbox, to see what ev will archive when a normal run is being done.

Additionally (as you inherited the install ;-) ) verify the Site and Task-schedule, and check the task is in 'normal' mode (task-properties, general tab line = report mode should be not ticked, and verif EV is not in backupmode (expand store, check column in right pane)

If policy is to archive everything older than 30 days, you might want to change that to 2 days (for TEST-purposes!) and see if that helps.

Also reconfirm your mailbox is enabled for archiving, but that should be good.

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

SWilson001's picture

Hi Gertjan, Thanks for you comment

The Archiving Strategy is set to "Based on age and quota", Age Based is set to 180 Days and Quota to 10%

The Task Schedule was set to after "6pm", but the Site Schedule was set to "Never" (I have now set it to selected times - Between 6pm to 6am - and restarted the EV Services)

I have attached a copy of the report in excel format,

So if I understand you correctly, items in my exchange account won't archive for another 180 days even if they weren't in the imported PST?

Thanks

Simon

GertjanA's picture

Hello Simon,

Task-schedule overrides site-schedule. (so if your site schedule is never, but the task is 18:00 to 22:00 (I cannot get used to am/pm ;-)), the task will run from 18 to 22. So, you can revert the site-schedule setting if needed.

The report shows there are items eligeble for archiving, but items to be archived = 0

Imported items from the pst will be archived after 180 days.
Items in your mailbox NOT from the pst will be archived after 180 days. Quota is tricky..

You set it to 10% this means EV starts archiving when the mailbox reaches 90% of it's defined max size. (Archive items until mailbox available storage reaches 10% FREE) Check the HELP button, and the Administrators guide for better explanation on this.

What you could do is make a new policy which you assign to yourself (using a different provisioning group) having a setting of archive everything older than 3 days. That will archive all items older than 3 days from your mailbox.

What you now experience is 'works as designed' ;-)

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

SWilson001's picture

Hi Gertjan,

Think I am still having problems, as nothing additional has archived,

I have created a new Provisioning Group called "Fix Archiving" to which I have added myself
I have created a new Policy called "Fix Archiving" which is set mainly with the default settings, but to archive items older than 3 day's
I have ran the Archiving task for the relevant Mail server, it still doesn't seem to be archiving anything further

I have attached the report,

Am I missing something or is something broke?

Thanks

Simon

GertjanA's picture

Hello Simon,

For you to get the new policy, you have to run the provisioning task, then sync the mailbox.

Rightclick provisioning task, run now. check the report (program files\enterprise vault\reports somewhere) to verify your mailbox got the new policy assigned.
Rightclick archiving task, synchronization tab, synchronize selected mailbox, select yours, sync.
Rightclick archiving task, run now, selected mailbox, your mailbox OR do a report run, and compare with previous report,

You now still have the 'old' policy assigned to yourself, so that won't change a thing (yet).

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

SWilson001's picture

Hi Gertjan,

Cool, didn't know about that, have tried it but still running into problems,

Changed the Rank of the polices so "Fix Arching" hits both mine and my boss's accounts before the default, which it now does

The "No of items ready to archive" in my account has gone up to 2 (there are 1000's of emails in my account) it has stayed at 0 for my boss's account, doesn't strike me as right

Any more ideas???

Many Thanks

Simon

Rob.Wilcox's picture

So you exported the items to a PST, and then dragged and dropped them in to your mailbox?

If so, then those items will have a Restored Date on them..  and won't be eligible for (re)archiving until the number of days listed in your policy from the restored date.

SWilson001's picture

Hi Rob,

Thanks for the info, I am still getting used to enterprise vaults eccentricity, still very new with it.

I restored the PST directly into enterprise vault, so they are still achrived,

Its all the other emails failing to archive, I have set all my email to archive after 3 day's (it was 180 day's but I change the policy yesterday)  but the last archived email was 28/1/2010. This has only been a problem since I disabled and re-enabled my account. All other accounts are working fine (Apart from my bosses. in which he did a similar thing). I am wondering if there is either a flag set some where that has it still disabled even though it appears enabled, or I am missing some configuration item.

This probably wouldn't usually be a problem as you wouldn't normally need to disable and reenable accounts etc. But our university is broken up in to "colleges", and each "college" has its own Enterprise vault server, as a result if staff and students move department, they may need to be on a different Enterprise Vault server hence I need to make sure I can get it working

Thanks

Simon

GertjanA's picture

upgrade to 8 sp4, that way you get Move Archive, which will take away the need for this at all ;-)

see http://seer.entsupport.symantec.com/docs/351473.htm

In your Outlook, click on EV icon while holding Shift+CTRL keys. click on Vault Information, scroll down to Hidden Messages in Folder header.
Is the modification date showing there the the date you actually applied the new policy?
In vault console, rightclick Exchange (under sitename\targets), select display Policies assigned to Mailboxes. Find yours.
Does the provisioning group fit, and the policies?

And, those 1000's of email, are they somehow imported?

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

SWilson001's picture

Hi Gertjan,

Thanks for you suggestion, we have been told to keep the EV servers roughly inline with the other University Colleges, which is SP2, hence I have upgraded to SP2

Still no luck though,

I have now removed all archived items from my mailbox , and made sure it is still enabled, but it is still failing to archive,

Its showming my index of archived items as 1-0

Anyideas?

Thanks

Simon

SWilson001's picture

Okay, I have gone away tried a few thing, learnt alot more about EV,

The current state of my issue is as follows,

We have upgraded to Version 8 SP5,

Archiving task works on all accounts except mine,

I can manually archive on my account via OWA (which is setup on a different server and probably uses a different account to do the archiving)

I can't manually archive via the outlook addin

I can manually unarchive via the outlook addin/OWA

My mailbox still isn't archiving via the archive task...

This looks to me as a permissions issue, but the account that is doing the archiving has admin rights over exchange. Any ideas?

Thanks

Simon

WiTSend's picture

I would zap the offending mailboxes first.  You use EVPM to zap a mailbox.  Zap removes all the hidden messages so that the mailbox appears to be "new" to EV. 

Then re-enable them and retest.