Video Screencast Help

Enterprise Vault Index missing SAVESETs and also missing from DB

Created: 13 Jun 2012 • Updated: 08 Dec 2012 | 12 comments
mumair109917's picture
This issue has been solved. See solution.

hi all,

 

we are using EV 9.0.1 windows 2008 R2 Enterprise Edition:

we are facing a problem for that i have open a case in symantec supoort as well but failed to find any way out know i am creating this forum with hopes.

PROBLEM DETAILS:

some of the users are not able to see their archived items for particular dates, when i checked DB refernce for that SAVESET ID it was missing from DB and also from Indexes even we tried EVSVR and Indexchecker -f but no success, but we have that saveset in vault store the DVS file now is there any way to open this DVS file so users can have their emails.

Comments 12 CommentsJump to latest comment

JesusWept3's picture

Where is the DVS file located? In a collection/cab per chance? It sounds to me like it was a user delete OR you restored the vault store databases

You can just use EVSVR to put the DVS references back in to the DB as a repair option

mumair109917's picture

jesuswept!

 

i have tried to repair using EVSVR but no success DB References and Indexing reference also missing but still i have only DVS file now i have only DVS file is there any way to use this DVS file to open that?

JesusWept3's picture

Is the DVS file in a CAB?

mumair109917's picture

no its not in the cab file it in my store located path like below

G:\Enterprise Vault Stores\GH MBX Vault Store Ptn2\2012\01-05\0\0FE

mumair109917's picture

hello,

 

still waiting for replies any one there????

JesusWept3's picture

What EVSVR oprions did you use to repair it?
Also what methods did you use to make sure it truly wasn't in the index??

My guess would be the item is a deletion
It removes the item from the index and stays in the journaldelete table and it's just waiting 14 days for it to be deleted from disk

Which probably would explain why EVSVR isn't working against it because there is nothing to repair

If its not that, you're either using the wrong EVSVR options to repair it or it really is in the database and index, it's just you're lee arching incorrectly

SOLUTION
mumair109917's picture

EVSVR tool was ran by Symantec Support Engineer via WebEx Session, and we also check some some save set from SQL Query but found them missing from SQL DB

Ameen's picture

You may have to upgrade your server to latest version and try using the latest EVSVR tool. When i have similar issue support did send me latest EVSVR and asked me to use the new one by stating that they did find some issue with the OLD EVSVR,

Please find the below article about EVSVR tool which may help you,

http://www.symantec.com/business/support/index?page=content&id=HOWTO57374

http://www.symantec.com/business/support/index?page=content&id=HOWTO57347

mumair109917's picture

hi ameen ,

 

in my case i have lost my DB entries for those savesets and indexing as well what i have is only DVS file of that save set

JesusWept3's picture

Check the JournalDelete table for the item.
it really sounds like a user delete

TypoProne's picture

After you take a look at the JournalDelete table and determine if using the dumpster is the proper route for you to recover the item. If you have the files on disk you should be able to recover it using EVSVR. Did you run EVSVR with a date range ? Is it possible you are looking in the wrong Vault Store DB for the specific item? Is it possilbe your Vault store paritions are doign something crazy like pointing to the same storage location?

 

THe million dollar question is if you worked with support on this, and they helped to identify that you have the item on disk, and ( I would assume) also determined that it was not deleted, what did they tell you to do to get it back when EVSVR did not fix it with their steps?

 

Sounds like you are working with support already and this should be something they can bring home with you.....

 

I am with JW2 on this. I think that there is no reason that there should be an item plainly sitting on teh disk that is not in the DB and is not identified by EVSVR as needing to be repaired. Does the EVSVR report generated refernce the file? 

 

I hope someone here helped you to work this out and you keep us posted on teh solution (by marking the solution in this thread naturally). 

 

Regards. 

 

TypoProne's picture

Any updates on this? If this has been resolved via help from one of the above postings... can you please flag it as the solution? If not can you please get back to us with the answers to the questions above. Doing either will help to ensure that the forum's resouces are used where they are most needed... 

 

Thanks in advanced. 

 

Regards