Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Enterprise Vault policy scheduling confusion

Created: 19 Jun 2013 | 2 comments
user022013's picture

Hi All,

I am currently confused as to when I should be scheduling my Enterprise Vault policies.  I have read Technote150237 and the NetBackup EV Admin guide and both say not to overlap the policies, but when I look at the white paper on page 13 it says the Timing of the backups is recommended thus:

'...that the backup of Enterprise Vault databases be started around the same time as Enterprise Vault index and storage volumes for all Enterprise Vault servers to privide the best consistency.'

and

On page 1  'It is highly recommended that SQL databases be backed up at or nearly the same time as other Enterprise Vault data such as vault store partitions and indexes.'

Yet on page 20 it says of the Database backups that 'These particular databases cannot be backed up with Enbterprise Vault ovjects such as indexes or Vault Storre partitions and must be in their own policy when using NetBackup Enterprise Vault agent.'  - Does this mean they can't be in the same policy which they can't be, but can be backed up at the same time or must be in a separate policy and can be backed up at the same time.

 

Currently I have the necessary policies set correctly as confirmed by Symantec support but my question is about the scheduling.  Symantec have seen the scheduling and not made any comments about all the policies running at the same time.

The policy with the Fingerprint Db and Open_partition run 10 minutes earlier than the Index_Location and Database policies do.  These last two set off at the same time.

Is there anyone who can clarify exactly what is the correct scheduling when using the Enterprise Vault agent?

Regards.

Operating Systems:

Comments 2 CommentsJump to latest comment

user022013's picture

I might add we are running a NetBackup 7.5.0.5 environment, all EV servers are at the same level, and EV 9.0.4.

None of our backups are failing.

Rick Stone's picture

It is recommended to back up your EV Directory database separately from your Vault Stores and Indexes because of "backup mode".
Vault Stores and Indexes must be put into "backup mode" prior to taking a snapshot of them and backing them up.  The NetBackup EV Agent does this automatically.

It's a relatively minor issue, but if you backup your Directory database at the same time as your Vault Stores and Indexes, because they are in backup mode at the time the Directory database is backed up, if you ever have to perform a restore of your Directory database, you will find that your Vault Stores and/or Indexes will suddenly be in backup mode.  It is easy to over look this and you'll be left scratching your head for a while wondering why EV isn't archiving or indexing new items.

You do want to perform the backups as close together as possible, but the items where consistency is critical is your Open Partitions, Vault Store databases, and your Fingerprint database.