Video Screencast Help

Enterprise Vault: Purged Exchange account then recreated

Created: 16 Feb 2014 • Updated: 16 May 2014 | 10 comments
This issue has been solved. See solution.

Hi all,

I'm hoping someone can help me, we had an issue with a user’s Exchange (2010) account, Microsoft were called in and after many hours on the phone they said the only option was to disable (purge) the Exchange mailbox and then re-create the mailbox account.

This was done and the mail PST imported and I now have the issue where I need to re-associate the existing Enterprise Vault archive (version: to the users newly created mailbox which has been associated to the existing AD account.

In Outlook (2010) it seems the archived items (stubs) in the mailbox are able to be opened but not restored as the restore icon is not available.  I went on to the Enterprise Vault server to see if I could associate the mailbox to the existing archive although this seems to already be the case, so I went to enable the disabled archive, I disabled it before I deleted the mailbox, but there is no disabled item for this account only a new which is ready to be enabled for archiving.

When I check in the SQL database (EnterpriseVaultDirectory) I can see two records in the ExchangeMailboxEntry table for the user, but I am not too sure what I am looking for in order to get this resolved.

Any advice greatly appreciated.

Operating Systems:

Comments 10 CommentsJump to latest comment

TonySterling's picture

One of the accounts in the ExchangeMailboxEntry table will have an entry in the DefaultVaultID.  You can delete that entry and then you should be able to enable the new account and choose that archive.

You could actually delete both entries and then re-run provisioning and synchronization and then enable the mailbox.  Either way should work.

TChipperfield's picture

Thank you Tony, removing both entries from the table and running the provisioning task worked a treat, I was then able to enable the new mailbox which as you said instantly gave access to the exising archive.

Thanks again!

TChipperfield's picture

Hi Tony,

I have just noticed there are now two entries against the account in the Vault Admin Console, I can see that new items being archived are being placed in the newer entry.

Can you suggest anyway to point this back to the older one?

Many Thanks

TonySterling's picture

So you have two archives for this user?

What you could do is to disable the user.  Export the items from the new archive back to the mailbox.  Delete that archive.  Then enable the user and point to the old archive.

To make it easier to distinguish between the two you can rename the archive you need to delete.

TChipperfield's picture

Sorry, that wasn't very clear, yes I now have two archives for that user.

I'm good with what you just said up until the point of...

"Then enable the user and point to the old archive."

After I disable the archive, export and delete would you expect the older archive to show within the "enable archive" wizard?

Many thanks for taking the time to respond.

TonySterling's picture

yes, once you delete the archive you don't want you should only see the desired archive in the wizard.


TChipperfield's picture

I'm stuck at the deletion stage I'm afraid... the newer archive currently has a state of "Marked for deletion" but isnt going anywhere.  Before I deleted the archive in the Enterprise Vault console I moved it to a retention category that allowed for deletion, ran the proviosioning task and then deleted it.

I'm assuming this archive should have gone completly but I went ahead and checked to see if I could enable the archive with it being marked for deletion but not such luck :(

Have I missed something here?

Many Thanks

TonySterling's picture

No, you don't have to wait as it will have the status of Deleting. You should be able to re-enable.

What happens when you try to enable them.

TChipperfield's picture

When I go to enable them via the 'Enable mailbox for archive wizzard" the mailbox simply does not show up, so I am unable to proceed any further.  During the wizard I looked in both the new mailbox section and the disabled mailbox section, but no sign of it :(

TonySterling's picture

Are you sure you disabled it?  You might double check the disabled mailbox wizard.