Video Screencast Help

Enterprise Vault Server error after upgrade from 10.0.1 to 10.0.3

Created: 22 Mar 2013 • Updated: 04 May 2013 | 1 comment
JMARIANIR's picture
This issue has been solved. See solution.

Hi everyone

We have an issue with Enterprise Vault Server after upgrade it.

We've just upgraded our Enterprise Vault lab server from 10.0.1 to 10.0.3

The server runs the Enterprise Vault services, and Discovery Accelerator is collocated in the same server.

I followed the steps documented in the upgrade guide

First I upgraded Discovery Accelerator component, and finally the Enterprise Vault services.

The installation process was successfull in all cases, and the DBs were updated  too without problems.

However, when we check the application, we saw that the "Exchange Provisioning task" is in an error status, without options to restart or delete the task. We restarted the "Task Controller Service" (and the server too) and while the service was running ok, the following event is logged in eventviewer:

---------------------

Log Name:      Symantec Enterprise Vault

Source:        Enterprise Vault

Date:          3/22/2013 1:09:19 PM

Event ID:      4190

Task Category: Task Controller Service

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      SERVERNAME.domainname

Description:

An error occurred in the thread control of the Enterprise Vault .NET server processes

Error: <0x80131040>

Reference: LSM/cci

Additional Info: KVS.EnterpriseVault.SystemServerManager

---------------------

 

Investigating, I found this article refered to old Enterprise Vault versions:

http://www.symantec.com/business/support/index?pag...

It talks about a wrong DLL registered in .NET Framework  (KVS.EnterpriseVault.SystemServerManager.dll)

 

Following this guide, I've checked DLL versions registered in the registry, and I found out that all the "KVS.EnterpriseVault.....dll" files are incorrectly registered!!:

The registry key ...\CLSID\{0F0B6694-D007-432A-AD0E-4E1CC18B9DB3}\InprocServer32\ shows the old version of files (10.0.1) and not the newer (10.0.3). We've tried to repair the installation with same results.

The article too talks about run the RegAsm.exe to register manually the DLL files:

RegAsm.exe /tlb /codebase /silent "C:\Program Files\Enterprise Vault\KVS.EnterpriseVault.ServerManager.dll"

Trying to run this command, display error status. I think the errors are related to Windows 2008 x64 operating system. May be we need to run the "RegAsm" command with others arguments in W2K8 R2... I don’t know. But we need to register all the DLL files.

 

Somebody has seen this problem?

Some special way to run "RegAsm" in W2K8?

I need help to repair the installation

 

Thanks in advance.

Regards

Javier Mariani

Operating Systems:

Comments 1 CommentJump to latest comment

TonySterling's picture

Hey ya,

sorry for no response, I just came across this.

Were you able to resolve this with the following: Article URL http://www.symantec.com/docs/TECH61287

Regards,

 

SOLUTION