Video Screencast Help

Enterprise Vault upgrade

Created: 20 Aug 2013 • Updated: 09 Sep 2013 | 11 comments
Aniyo's picture
This issue has been solved. See solution.

Hi Guys,

Need some help with an EV upgrade I'm currently doing for a client (Ev8 > EV9 > EV10)

The upgrade to EV9 seems to have worked, but when I try to upgrade to Ev10, the Deployment scanner shows an error - that the current version is 8.0 nad cannot be directly upgraded to Ev10.

The Admin Console, and the add/remove programs indicates that EV 9 is currently installed.

The server has been rebooted after the upgrade but error still comes up in the Deployment scanner,

Has anyone come across this before? any advice will be greatly appreciated.

Thanks

 

Operating Systems:

Comments 11 CommentsJump to latest comment

Pradeep_Papnai's picture

You can confirm current EV version by information supplied in Tech note http://www.symantec.com/docs/TECH70211

The EV Binaries Version can be found in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Install
"Version"=  
On a 64bit OS everything is under a WOW6432Node key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install

The EV Directory Database Schema Version can be found by running the following SQL query:
 
USE EnterpriseVaultDirectory
SELECT SchemaVersion FROM DirectoryEntry

The EV VaultStore Database Schema Version can be found by running the following SQL query:

USE EnterpriseVaultDirectory
SELECT SchemaVersion FROM VaultStoreEntry

Just to update you, upgrade to EV 10.0 cannot be done directly untill you have base OS is win-2008 R2-64 bit or later, In that case you need to migrate EV server from 32 bit to 64 BIT OS. http://www.symantec.com/docs/HOWTO42445

A_J's picture

Hi Aniyo,

 

Apart from the above details could you please provide the environment details such as..

 

Enterprise Vault Server is in Cluster ?

Event ID logged after the upgrade.

Operating system on EV Server.

 

Aniyo's picture

Hi Guys,

Thanks for getting back to me.

I have checked the registry key @ HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install and the full version shows as 9.0.4.1097

I have also run the sql queries for the Directory and Vault store database schema and they came up as version 9 as well.

The server is a Win Server 2008 R2, x64 and is not in a cluster.

Thanks

 

 

A_J's picture

Hi Aniyo,

 

Could you please upload the CAB file or a screenshot of the error when you run the deployment scanner..

Also do you get any error in the enterprise vault event logged while you run the Deployment scanner..

Could you do a find in registry for 8.0. and see in which key we have that the information present..

 

 

 

Aniyo's picture

Hi A_J

I have attached a couple of snips,

 The Install directory in the registry shows the full version as 9.04, but there is also another key called version 8.0 lite. not sure if that may be causing the issue

reg.PNG error.PNG
TonySterling's picture

When you upgraded to EV 9 did you change hardware?  What was the process you used?

Aniyo's picture

Hi Tony,

The upgrade from EV 8 > 9 was done on the same server - I just followed the instructions that came with the EV9 media.

A_J's picture

Hi Aniyo,

 

As per the screenshot it seems either the upgrade didn't went fine or registry was not updated properly..

As i can see the key

 

Version : 8.0-Lite   ------  It should be Version : 9.0.4.1097

&

ServerUpPath : 8.0.4.1991,8.0.4.1991 -- It should be ServerUpPath : 8.0.4.1991,9.0.4.1097

I think the problem is you ran the binaries of EV 9.0.4.1097 using Windows User account instead of VaultService account

So i would suggest to re-install EV 9.0.4.1097 binaries using vault service account it won't take much time.

Just stop EV Services and run setup.exe.

and then check the registry whether this value have been changed or not..

 

SOLUTION
Pradeep_Papnai's picture

It looks to me that there is some registry corruption due to EV client installation on top of server binaries.
'Kit Type' is showing as 'lite client' & Version is showing as '8.0 lite'.

I am afraid that you may need to rebuild EV server with current 9.0 sp4 version binaries after uninstall server & client binaries and install only EV server binary & run EV configuration wizard to repair EV services & registry.

Wait for Any more inputs before my suggestion.

A_J's picture

I would suggested to repair with EV binaries 9.0 SP4 with Vault Service account and then uninstall the EV Client if it is installed on the EV Server.

 

Aniyo's picture

Thanks for the suggestions guys, I haven't been able to work on it as I was unwell. I'll get on this tomorrow and post a reply.

Thanks again.