Video Screencast Help

ERR - Error encountered while attempting to get additional files for System State

Created: 09 Sep 2013 • Updated: 02 Apr 2014 | 15 comments
This issue has been solved. See solution.

2 Windows Server 2003 Clients backup ends with status 1.  Shadow Copies is disabled on all servers but these two are the only ones getting this error. I don't see a difference between these and the others that are working.    I have looked at other posts on the forum but they don't seem to fit.   I am running Netbackup 7.5.0.3 master server is RedHat  Media Servers are Solaris.  I saw something similar for version 6 but we are on 7.5.0.3.

09/06/2013 20:33:00 - Warning bpbrm (pid=19283) from client iisclient1: WRN - can't open object: System State:\Removable Storage Manager\Removable Storage Manager (WIN32 -536805679: Unknown error)
09/06/2013 20:33:00 - Error bpbrm (pid=19283) from client iisclient1: ERR - Error encountered while attempting to get additional files for System State:\
09/06/2013 20:33:09 - Info bpbrm (pid=19266) media manager for backup id iisclient1_1378504829 exited with status 0: the requested operation was successfully completed
09/06/2013 20:33:09 - end writing; write time: 3:29:40
the requested operation was partially successful  (1)

Problems Log :

Fri Sep 06 20:33:09 CDT 2013    MediaSvr252    iisclient1    Error    87926    Backup    backup  of client iisclient1 exited with status 1 (the requested operation was partially successful)    nbpem
Fri Sep 06 20:33:00 CDT 2013    MediaSvr252    iisclient1    Error    87926    Backup    from  client iisclient1: ERR - Error encountered while attempting to get additional files for System State:\    bpbrm
Fri Sep 06 20:33:00 CDT 2013    MediaSvr252    iisclient1    Warning    87926    Backup    from  client iisclient1: WRN - can't open object: System State:\Removable Storage Manager\Removable Storage Manager (WIN32 -536805679: Unknown error)    bpbrm

Operating Systems:

Comments 15 CommentsJump to latest comment

ilovemywillow's picture

I should not have included the removable storage manager error in this.  The issue is with the system state files not being backed up and generating the error.  This is happening on this server as well as another.  This server has Removable Storage Manager disabled. The other doesnt evern have that service. 

The issue is ERR - Error encountered while attempting to get additional files for System State:\

ilovemywillow's picture

Ok I'll try that.  This client had open file backups enabled but was using VSP.  I dont understand why but some windows clients are using vsp and some are using vss.  This is and one other are the only ones that failed. 

quote:  "Check the Windows Open File Backup setting on the master server to ensure VSS is being used
Host Properties > Master Servers > (master) > Client Attributes > Windows Open File Backups tab
Ensure the client name is added to this list, then highlight client in the list, and select 'Use Microsoft Volume Shadow Service (VSS)'"

watsons's picture

If you set these 2 windows 2003 clients to use "VSS" via the master server "Client Attributes", there is no reason why it still use VSP except:

- you haven't run a "bprdreq -rereadconfig" to refresh the setting on master server. OR
- "Volume Shadow Copy" service was disabled in the client. OR
- "Volume Shadow Copy" service is enabled, but not able to start properly due to OS issues, if this is the case, you need to check system & application event logs for more details, or contact Microsoft support.

ilovemywillow's picture

I thought this was solved but now I have a client with the same error but they have VSS enabled correctly. I am not sure which log to look at but since the below indicates error from bpbrm I created that log directory and am rerunning the backup.  The backup is a diff.  The errors we are seeing are intermittant and inconsistant with clients.  Hard to figure out.

Error from job display in java console

09/11/2013 17:08:57 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\System Files\System Files (WIN32 -536805679: Unknown error)
09/11/2013 17:08:57 - Error bpbrm (pid=7081) from client ifwlwss1: ERR - Error encountered while attempting to get additional files for System State:\
09/11/2013 17:08:57 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\Automated System Recovery\BCD\BCD (WIN32 -536805679: Unknown error)
09/11/2013 17:08:57 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\Internet Information Services\IISCONFIG (WIN32 -536805679: Unknown error)
09/11/2013 17:08:57 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\Internet Information Services\IISMETABASE (WIN32 -536805679: Unknown error)
09/11/2013 17:08:58 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\COM+ Class Registration Database\COM+ REGDB (WIN32 -536805679: Unknown error)
09/11/2013 17:08:58 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\Registry\Registry (WIN32 -536805679: Unknown error)
09/11/2013 17:08:58 - Warning bpbrm (pid=7081) from client ifwlwss1: WRN - can't open object: System State:\Windows Management Instrumentation\WMI (WIN32 -536805679: Unknown error)

watsons's picture

what is the backup selection in your policy setting?

If it's set to "System_State", try not to use that and change it to "Shadow Copy Components" directive. If you have been using ALL_LOCAL_DRIVES (which include the above), try to split it into and see how it goes:

C:\
NEW_STREAM
Shadow Copy Components:\ 
 

More details in http://www.symantec.com/docs/TECH35151

Mark_Solutions's picture

Agree with watsons - the key may be in what you have in your selection lists

ALL_LOCAL_DRIVES is fine (as long as you do not have anything else also in the selection list) but if you have System State change it to Shadow Copy Components as System State is for Windows 2000 / XP only.

Also worth asking what the server actually does as sometimes being an application server (AD, Exchange etc.) can also have an affect on things - as can be virtualised when the VMware tools can affect the VSS processing.

You said earlier that the clients were set to use VSP - but that does not actually exist in 7.5.x - are your clients definately on 7.5.0.3?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Will Restore's picture

That's worth a try.  But I never read it that way. 7.5 Admin Guide quote (emphasis added)

 

System State:\ directive

The System State:\ can be used on Windows 2003 systems and later.

 

The System State:\ directive is needed for the operating system versions which

do not support Shadow Copy Components, such as Windows XP.

 

Windows 2003 Server computers recognize the System State:\ directive and

behave as if following the Shadow Copy Components:\ directive. A message

informs the user that this directive translation occurred.

 

The System State:\ directive creates a backup for critical system-related

components. The exact set of system components that are backed up depends on

the operating system version and system configuration.

Will Restore -- where there is a Will there is a way

ilovemywillow's picture

Thanks for all the feedback! 

Watsons:  The backup selection in your policy setting is ALL_LOCAL_DRIVES with the  understandign that this will catch the shadow copy components and system state.

Mark_Solutions:  The server being backed up.. at least one of them.. is an IIS server. The other is a sharepoint server but is not in production yet.. just being built.  The issue is not every night and not always the same server.

Mark_Solutions:  When I go into master server properties and click on client attributes then Windows Open File Backup tab it shows the Snapshot Provider.  I did read in the admin guide that windows clients default to VSS for 7.5 but was wondering why the console has this as configurable.  Anyway I looked at windows clients and noticed some are configured to use VSP in this gui.*  This may be a different issue because the servers with the system state error show up as using VSS.

My clients are on 7.5.0.3

 

*In the example screen shot aodoratest is a windows server

 

vsp-versus-vss.jpg
Mark_Solutions's picture

That setting may have been there prior to you going to 7.5

I would change any set like that to use: VSS, individual drives, disable and continue

Of course unless there is a specific reason for the clients being in there such as going through a firewall or similar then remove them - they are not there by default so someone has added them in there.

As requested it may take higher logging levels to pin things down - also check the event logs to see if anything shows up when the backups run

Are they physical, virtual or a mix?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

ilovemywillow's picture

Mark_Solutions:  We upgraded so maybe it was there from the previous versions.  I can remove them all from client configuration setting in master server properties?   No firewall pass through just a mixture of unix and windows and physical and virtual.  (about half and half for both)

If I remove them the unix will default to the proper snapshot provider as will the windows?

 

rookie_11   Working on getting that.  Will those reports be on the client or media server?

 

 

Mark_Solutions's picture

If you remove them all and all your clients are 7.5 then everything will use the standard defaults for all settings which are usually fine - after all there are not any servers in there on a new system - they have all been added manually at some point - and that is sually due to snapshot issues on Windows in per V7.5 environments.

If in dount keep a copy of the client folders from \netbackup\db\client\ - this is where all of the settings are stored so you have a record of everything and can always pop a folder back if you do have an issue with a client

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
RecioLola's picture

I have the same issue.

How did you resolve the problem then?.

Netbackup 7.5.0.6 at client, and i have the error:

 01/22/2014 04:25:36 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State: (WIN32 -536805685: Unknown error)
01/22/2014 04:25:37 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State:\System Files\System Files (WIN32 -536805667: Unknown error)
01/22/2014 04:25:37 - Error bpbrm (pid=10674) from client client1: ERR - Error encountered while attempting to get additional files for System State:\
01/22/2014 04:25:37 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State:\COM+ Class Registration Database\COM+ REGDB (WIN32 -536805667: Unknown error)
01/22/2014 04:25:37 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State:\Windows Management Instrumentation\WMI (WIN32 -536805667: Unknown error)
01/22/2014 04:25:38 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State:\Event Logs\Event Logs (WIN32 -536805667: Unknown error)
01/22/2014 04:25:38 - Warning bpbrm (pid=10674) from client client1: WRN - can't open object: System State:\Registry\Registry (WIN32 -536805667: Unknown error)
01/22/2014 04:25:38 - Info bptm (pid=11209) waited for full buffer 1 times, delayed 1052 times