Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error 1068: the dependency service or group failed to start

Created: 26 Oct 2009 • Updated: 21 May 2010 | 3 comments
This issue has been solved. See solution.

Today I changed all the Backup Exec services that were using the Administartor account to logon using an account that I created that is a member of Backup Operators group.

Now when I try to start Device & Media, Job Engine and Backup Exec Server services, I get this 1068 error, with 7001 and 7023 error logs in Event Viewer.

Did some research....
I checked these 2 issues:
- Made sure the MSSQL$BKUPEXEC service was started
- Checked folder permissions on the Veritas folder under Program Files

I found the suggestion below but, there is no Bewinui.ini file.

I did this same thing, change the service logon accounts, on a server running BE 8.6 and had no problems.

Any suggestions?

-----------------------------------
This error message can also occur if the Backup Exec service account password have been changed.
To resolve this issue do the following:

1. If the Operating System is Windows NT4, Click on Start | Settings | Control Panel | Services or If the Operating System is Windows 2000, click on  Start | Programs | Administrative Tools | Services
2. While the Backup Exec services are stopped for each Backup Exec service, type in the password and confirm the password.
3. Then Open Windows Explorer
4. Navigate the Backup Exec directory (the default directory is C: Program files/Veritas/Backup Exec/NT/ Data) to the Data sub directory.
5. Rename the Bewinui.uni file in the Data folder to Bewinui.old.
6. Close Windows Explorer and Start the Backup Exec services.

Warning: As a results of renaming the Bewinui.uni file all user -defined shares will be lost. Thus, all user-defined shares will need to be re-created, all stored authentication will need to be re-entered, and all notifications will need to be re-created.
-----------------------------------

-------------------------------------
Event ID:    7001
Description:
The Backup Exec Server service depends on the Backup Exec Device & Media Service service which failed to start because of the following error:
The database specified does not exist.
--------------------------------------

-------------------------------------
Event ID:    7023
Description:
The Backup Exec Device & Media Service service terminated with the following error:
The database specified does not exist.
-------------------------------------

Comments 3 CommentsJump to latest comment

Colin Weaver's picture

If your accounts are only Backup Operators, even if you fix this issue you are likely to experience other problems - for instance you can't access VSS writers (for various applications) correctly without at least local administrator rights to the servers.

You actual issue may well be that you don't have permissions within the Backup Exec database after changing the security of the service account so in theory might be solved by using SQL Studio Management Express - but as you are almost certainly going to experience other problems I would recommend you make the account at least a local admin, if not a domain admin for the environment.

Ken Putnam's picture

Seagate, then Veritas, and now Symantec have always said that the BackupExec services should run with  Domain Admin priviledges (or local Admin on all machines backed up, at the very least)

You may get backups to work with Backup Operator only (tho I doubt it), but NO restores will ever work without Admin rights

If this response answers your concern, please mark it as a "solution"

SOLUTION
John Brigan's picture

Well that was simple.
My mistake, I thought Backup Operators was enough.
I made the account a member of Domain Admins and all Service started.
Thanks.