Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

error 129 Disk storage unit full

Created: 23 Jul 2014 • Updated: 07 Sep 2014 | 7 comments
This issue has been solved. See solution.

Hello,

I have been getting error 129 on some of my backups. it looks like I have a PureDisk disk pool that has reached it's high water mark. As the Disk Pool is a lun from a NetApp, I asked the SAN admin to give me some more space. After getting more space I got the Solaris 10 media sever to see it with this comand.

zpool set autoexpand=on bupool

Any way Netbackup still sees the volume at it's old size. How do I get NetBackup see the new space?

Also if I needed to do more stuff on the Solaris side let me know.

My enviremet.
Master server NetBackup 7.5.0.7 Solaris 10
Media server NetBackup 7.5.0.7 Solaris 10

Operating Systems:

Comments 7 CommentsJump to latest comment

cyberninja's picture

update,

I was able to get the new space to show up in NetBackup in the Disk Pools section. I'm how under the high water mark, but above the low water mark. When I run the backup job I still get the 129 error. What gives.

Riaan.Badenhorst's picture

I would restart the services. Then go to devices > disk pools > your pd pool > change > update/refresh the configuratoin

Regards,

Riaan Badenhorst

You need an OpenVision to see the truth about Backups. Restores are a plus. But that's just Semantics ;)

ITs easy :)

cyberninja's picture

I add some more space to the Disk Pool. I updated/refreshed the change in the configuration. Put I'm miss about 3 GB of storage. I then ran the crcontrol --getmode command.

Mode: GET=Yes PUT=No DEREF=Yes STORAGED=Yes REROUTE=No COMPACT=Yes RECOVERED=No

I think that my data store is crupted now.

What should I do now?

SymTerry's picture

Run the crcontrol --getmode command again. Does it still say PUT=No? If so, please look at the /log/spoold/spoold.log. Your looking for the line "Storage Cache Manager: load completed" if you don't see that, look for "Reason: ERROR: "

If you think the data store is corrupt, please open a support ticket and PM me the case number. 

SOLUTION
Marianne's picture

Are you using ZFS volumes for MSDP?

This is not supported.

See File System Compatibility in OS Compatibility Guide: http://www.symantec.com/docs/TECH76648

- ZFS file system is not supported as a backend storage location for an MSDP disk pool.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

cyberninja's picture

I call tech support and they where able to help me fix the issue. I was on the phone several hours. I think it ended up being a firewall/networking issue. The case number was 0711815. Looking though the case notes I can't see what the fix was.

Marianne's picture

Please do not ignore the fact that ZFS is not supported for MSDP....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links