Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error 20060029 after upgrade from 7.5.0.4 to 7.5.0.6

Created: 17 Jul 2013 | 9 comments

Master: W2k8 R2 x64 running 7.5.0.6 (upgrade from 7.5.0.4)

Media Server #1: 5220 running 2.5.1 + Rebase patch ( configured for two pools, one PureDisk, one AdvanceDisk)

Media Server #2: W2k8 R2 x64 running 7.5.0.6 / OpsCenter 7.5.0.6 (both upgrade from 7.5.0.4)

Media Server #2: W2k8 R2 x64 running 7.5.0.6 with small MSDP for testing (upgrade from 7.5.0.4)

 

I'm currently awaiting a callback from Support about this but figured I'd bring it up here also.

After upgrading the Windows side of the Domain, all backups that get assigned to a Media Server other than the 5220 fail with an Error 20060029 / Error 83 when writing to the 5220's PureDisk pool.

Imports of data that has been replicated via AIR from another site are also throwing 191's.

Backups to the 5220 AdvanceDisk and to the MSDP work fine.

 

I fought through the issue last night and thought that it was fixed.  Only for it to return with a vengence tonight.  I tried a reboot of the 5220 and that made it even worse.  The only thing that seemed to help was to deactivate the SLP's at the other site and disable all Media Server checkmarks for everything except the 5220 itself on the PureDisk pool.

I also can't open the properties of that disk pool.

 

So I think somewhere along the line that some password or credentials got lost...

 

Operating Systems:

Comments 9 CommentsJump to latest comment

D.Flood's picture

Short term work-around:

1) Open NetBackup GUI

2) Go to NetBackup Management

3) Go to Storage

4) Go to Storage Units

5) Double click on the Storage Unit

6) Uncheck all Media Servers other than the actual Appliance

7) Click OK

 

 

D.Flood's picture

EDIT: Incorrect fix deleted

It turns out that there is some sort of bug (my definition, still waiting on confirmation from Support) in 7.5.0.6 that makes it incompatible with a 5220 running 2.5.1.  Specifically the credentials.

On top of that there is evidence that 7.5.0.6 is using the wrong list of Media Servers to determine which one to assign to jobs.  It's using (or appears to use) the Credentialed list rather than the list in the properties of the actual disk unit.  So if you have a remote 5220 that can only use itself as a Media Server (or risk saturating your WAN) then you'll get bit by this bug...

I'll probably end up back-leveling/uninstalling everything and give up on 7.5.0.6.

 

CRZ's picture

With everything else already at 7.5.0.6, would you be able to apply 2.5.3 to the Appliance or is that a deal breaker?  (It would give you the added benefit of having the rebase fix without needing to apply an EEB!)


bit.ly/76LBN | APPLBN | 75LBN

D.Flood's picture

Upgrading to 2.5.3 is a last resort.  2.5.1 was enough of a trama that I'm hoping I never have to upgrade these 5220's.  It also would mean that my Master has to be 7.5.0.6 (right now I have the option of uninstalling and hopefully getting back to a working system if Support can't fix 7.5.0.6).  And if 7.5.0.4 worked with 2.5.1, 7.5.0.6 should also (if it was correctly regression tested before release).

And, the "picking random Media Servers that are unchecked in the storage unit properites" bug is fatal since I have a remote 5220 that can not use anything else as a Media Server or the entire WAN link gets killed.

Right now I have a Sev 1 case open but have had zero contact from my assigned tech all day today.  So I don't know if it is just Monday overload, she's out of the office, or if there are so many problems that everyone is too busy...I see they even shut down the live chat so I'm guessing 7.5.0.6 is causing a lot more problems than anyone wants to admit.

 

 

I like 3.14's picture

I upgraded from 7.5.0.4 to 7.5.0.6 recently.  All went well for a few days/week, but now I'm getting flooded with erros I rarely (or never) saw before.  I'm getting 191 errors on my SLP jobs, and 44 errors on most everything else (I never saw a 44 error previous to the upgrade).

 

Appliance (both - I have two 5220 appliances that replicate to each other) and Master Server all upgraded at the same time to 2.5.3 and 7.5.0.6 respectively.  I upgraded as both appliances were having issues with the data stores going off-line on a weekly basis.  What I ended up with is just as bad, only in both environments at the same time.

D.Flood's picture

I encourage you to call and open a ticket.  The 191's may be an issue similar to mine (a lot of my SLP/AIRs failed with that as the overall error). 

The only way that Support knows that there are problems with a release are if people call and open tickets.

 

D.Flood's picture

Well...It turned out that my 5220 was throwing (deep down in the logs) a "catalog is busy" error.  This was being misinterpreted by 7.5.0.6 as a credentials error.  After Back-Line helped find that error it was decided that since 7.5.0.6 was the destination anyway, the 5220 needed to be upgraded first and then the rest of the system.

One word of warning about an upgrade to 2.5.3, make sure your Appliance has at least eight hours after the reboot to finish all the behind the scenes updates before you throw a full load at it.  Mine went catatonic (responded to ssh but not NetBackup commands) twice in a one hour period because I didn't wait long enough.

So as of this morning I'm once again running 7.5.0.6 on the Master, Appliance, and all Media Servers.  We'll see what the overnight results are.

 

MatsHolm's picture

 

We upgraded a site 7.5.0.5 to 7.5.0.6 on monday, Master Server and two Windows Medias Server. Along with that we upgraded 6 clients (5 SQL and 1 large File server) to 7.5.0.6 as well.

After that we found Error 20060029 / Error 83 for all these clients along with Error 87. All these clients are configured with client-side dedup to a NBU 5220 (2.5.2). When changing to media server dedup it all works fine.

This morning we upgraded two 5220 to 2.5.3 and right now they are offline for disk (1 hour after restart) and both have the FC port "ling down" so no tape.

Did you have everything up and running on 7.5.0.6 and 2.5.3 now?

We have started a case with Symc and see where it leads

/Mats

D.Flood's picture

Yes, I finally got both sites fully upgraded to 7.5.0.6/2.5.3...

And the first time 2.5.3 came up it did take longer than expected, both because we hadn't rebooted lately (so Linux fsck auto-ran) and then the PureDisk system had to do some extra stuff. 

On top of that (as I previously mentioned) once it did come up it was somewhat unstable for several hours as it continued to do things in the background.  And I probably didn't help that any by running the client name case sensitivity fix script that's included in 2.5.3...

I'm willing to bet that by the time you actually talk to Support (their response time is a little slower than it used to be) that at least part of the Appliance should be back up and running.  Murphy's Law and all that...