Video Screencast Help

Error 239: SQL jobs after 7.5.0.7 upgrade

Created: 23 Dec 2013 | 14 comments

Last week I applied MR 7.5.0.7 and imedialty upon the next run of jobs several sql jobs faile with error 239.  I noticed that all the jobs failing had a capital first letter for the client name.  I changed all the letters to lowercase and that seem to correct the issue.  3 days later one of the machines is kicking out this error again.

There are not details in the job other than it shows "NULL" for the schedule.

Any ideas?

For the last 3 days backups were 100% successful using the lowercase names so it doesnt make much sense why this would just appear again. I've tried recreating the script files on the sql server and adding a capitol letter back to the name, but nothing seems to be working.

Master server: 2008 R2, 7.5.0.7

Media server: 5200 Appliance 2.5.3

Operating Systems:

Comments 14 CommentsJump to latest comment

Mark_Solutions's picture

What is the full text of the backup failures?

I am wondering if the conversation between master and appliance may be bringing the case sensitivity issue back up.

2.5.4 (or was it 2.6) is supposed to fix the case sensitivity issue so it may be worth applying the 2.5.4 patch to the appliance too.

Possibly worth patching the appliance to match anyway (and the client)

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Stanleyj's picture

Thanks Mark!  I actually was just starting to download 2.5.4 to see if that helps.  I was hoping to hold off until i went to 7.6.0.1 after the first of the year and then apply 2.6.0.1 to the appliance.  But oh well.

I did an upgrade lastyear on this very same day and then spent all of christmas trying to get the appliance back working again.  Wish me luck!

Mark_Solutions's picture

OK - well do take a look at the readme for 2.6.0.1 - it does talk about things being different depending on if you have bothered with 2.5.4 or not - it is the same as 7.6.0.1 relates to things being different if you installed 7.5.0.7

It is almost as if you are better going from 7.5.0.6 to 7.6.0.1 than if you were on 7.5.0.7 - dont really understand it all but check out the release notes for the appliance and netbackup first before taking the plunge!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Georges N's picture

Hey guys

I can confirm 100% that this issue is real. I updated from 7.5.0.6 to .7 yesterday and all SQL jobs from SQL 2008 R2 servers (and below versions) failed with code 239. SQL 2012 jobs were fine though...

So I tested by changing the case sensitivity (renaming in the batch file... from XXXXXXXXXX to xxxxxxxxx) and it works. I'm going to test changing it in the NBU console (policy --> change client names from XXXXXXXXX to xxxxxx or vice versa to match the batch file on the server itself)

I can't believe this wasn't checked before deploying this update though! I understand NBU is ported from Unix to Windows but I hear it's just one extra line of code to force all characters to upper case?

I hope Symantec can deploy a fix soon!

VPrata's picture

Have encountered the exact same problem when upgrading win master to 7.5.0.7.

Stanleyj / Mark_solutions, I also upgraded the media appliance 5220 to version 2.5.4 and problem remains.

Once I rolled back the master version to 7.5.0.5, everything was fine again (did not need to rollback appliance as it's not a "major" version change.

I have a support case open for this and Symantec has been able to replicate the issue. No patch for it yet though.

sclind's picture

I just upgraded  to 7.5.0.7 and started having this problem.  My clients are defined as 'hostname.domainname.com' yet come into the backup master as just 'hostname' (and then fail).

sclind's picture

we added just 'hostname' to the policy and seem to be OK.

Lee C's picture

Hello VPrata,

 

I wonder if you had any further feedback from Symantec regarding this?

I too have logged a ticket, but it has not been acknowledged as an escalated issue.

 

 

Master/Media NBU7.5.0.7 on W2k8 - VMware, SQL and Exchange agents, MSDP

OCA 7.5.0.7 on W2k8R2

 

VPrata's picture

Lee,

Not much to share. Support told me that a similar case had been escalated to backline and engineering. Still waiting for an update on the matter...

Georges N's picture

They announced that 7.5.0.7 would be the last update of the 7.5 series... maybe they are taking time looking into applying a quick fix (7.5.0.7b or similar)...

 

Any other systems affected except SQL? I haven't noticed the issue on Windows/Linux/Oracle/Exchange

Lee C's picture

Hi Georges N,

For us, it only affects SQL.

Master/Media NBU7.5.0.7 on W2k8 - VMware, SQL and Exchange agents, MSDP

OCA 7.5.0.7 on W2k8R2

 

Yogesh.Jadhav's picture

Hi Lee,

 Could you please try changing the case of client name or make sure client name is correct on the SQL server. Lauch the Netbackup client gui and check the client properties. If you see any difference in the name please correct it and check if it works.

Thanks & Regards

Yogesh Jadhav
Georges N's picture

Yeah, upper/lower case (match policy with the script) works - but any news from Symantec about a quickfix for this? Seems like an odd bug to let through the .7 update.

Also you might need to add the following line to your SQL scripts:

BROWSECLIENT "CLIENT_NAME_HERE"