Video Screencast Help

Error 247 while policy is active.

Created: 03 Mar 2013 | 7 comments
AB Chaudhry's picture


Backups are failing with error 247 while policies are active shown in Admin Console and output of bppllist command.


We are upgrading NetBackup Master from 7.0.1 to After upgrade the script to activate all policies was hanged and it was killed. A few policies were activated while other remained deactivated. The policies were activated manually but backups failed with error 247. 

Initial steps:

Policies were deactivated and activated again but backup failed with same error 247.

Policy was copied with a new name but backup failed again with same error 247.

Major incidents:

Post upgrade script to activate all policies was hanged and killed.

/tmp was full and netbackup was restarted automatically on same node of cluster in its native third attempt.

IPv6 has been disabled on AIX 6.1 with HACMP to avoid "CORBA time out" issues with NetBackup.

Operating Systems:

Comments 7 CommentsJump to latest comment

AB Chaudhry's picture

Environment details:

NetBackup: NetBackup Master upgraded from 7.0.1 to

Platform: AIX 6.1

Cluster: HACMP with two nodes, HA cluster

Faulty Policy Type: Multiple policies with mix policy types like Oracle, file system and others.

sazz.'s picture

It seems while activiting the policy after upgrade was killed or hung due to that the database is still behaving that it is not active. You forgot to post the output of the policy, please check the policy output via command and see if policy is showing active.

Try creating a new policy as a test and check if it works.


Marianne's picture

Also best to hard-code policy name in the backup script on the client.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Ankit Maheshwari's picture

Seems something is wrong with NBDB..,,

What logs showing,,,,

logs Plz...

Ankit Maheshwari

Mark_Solutions's picture

When did you do the upgrade (how many hours ago?)

Have you run the nbemmcmd -listsettings -brief -machinename mastername

to confirm that you upgrade has actually finished?

Please show us the output if the above command



Also .. did the image cleanup after the upgrade finish successfully?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

AB Chaudhry's picture

Thanks everybody for your valued comments and updates and sorry for dealyed update.

The backups started getting successfull suddenly after eight hours of upgrade. Initially the child processes of killed script are suspected to slow down the DB and keep running and updating things. Detailed investigations are in progress and will be updated if concluded to some positive specific results. Now everything is running fine, only the response of Master Server is slow. 

Mark_Solutions's picture

I think you will find that an image cleanup job will have run up until things started working again - which is why i asked about that and the output if the nbemmcmd as this shows when the upgrade has completed

Sounds like you will be OK now once it all settles down but may need to tune a few things to get the best out of the system following the upgrade

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.