Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error 3305 with Exchange 2010

Created: 22 Jul 2013 • Updated: 26 Jul 2013 | 12 comments
gilito80mx's picture
This issue has been solved. See solution.

hi everybody, 

i have this problem please help me.

I have EV 9.0.3 running on Win 2008 R2

and have mix exchange enviroment 20007 and 2010, all my enviroment Exchange 2003 working very well, but the new Exchange enviroment 2010 not work the Archive Task failed every when a i tray to start, i did make all the permissions settings, but its no posible, i have 3 Exchange server in HA, here is the trace log file.

 

thanks for the help.

Operating Systems:

Comments 12 CommentsJump to latest comment

JesusWept3's picture

So the error isn't with Exchange, but with MSMQ

Could not Locate the "248" Queue, call returned EVCLUSTERMSMQ\Private$\Enterprise Vault Exchange Mailbox Task for EX 110811170211 A1 |

Are Tasks on the same server working correctly?
you may just want to try deleting the task and recreating it, then it will create new MSMQ's and hopefully that will work

 

Pradeep_Papnai's picture

As per your dtrace permission & throttling policies applied correctly

375         21:34:17.789       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::CheckRunningAccountForMailbox - Executing query ((&(objectCategory=person)(|(&(msExchVersion<=2251799813685248)(!(msExchVersion=2251799813685248)))(!(msExchVersion=*)))(|(objectSid=S-1-5-21-1057578226-744824930-1563438338-1104)(msExchMasterAccountSid=S-1-5-21-1057578226-744824930-1563438338-1104))(!(objectClass=foreignSecurityPrincipal))))

376         21:34:17.789       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::CheckRunningAccountForMailbox - Completed query

377         21:34:17.789       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::CheckThrottlingPolicyDetails - Executing query ((&(objectClass=msExchThrottlingPolicy)(distinguishedName=CN=EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428,CN=Global Settings,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=vaultlab,DC=loc)))

378         21:34:17.789       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::CheckThrottlingPolicyDetails - Completed query

379         21:34:17.789       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::CheckThrottlingPolicyDetails - the throttling policy [CN=EnterpriseVault_D0F41A15-9E91-D111-84E6-0000F877D428,CN=Global Settings,CN=First Organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=vaultlab,DC=loc] applied to user [CN=EV Service,CN=Users,DC=vaultlab,DC=loc] has the correct RCAMaxConcurrency value

 

We can successfully run configmsgservice.

390         21:34:17.851       [4932]  (ArchiveTask)    <248>    EV:M     ConfigureMsgServiceAttempt - Trying ConfigureMsgService using PR_PROFILE_UNRESOLVED_SERVER=[EX], Attempt=[1]

391         21:34:17.961       [4932]  (ArchiveTask)    <248>    EV:M     ConfigureMsgServiceAttempt - ConfigureMsgService successful

392         21:34:17.961       [4932]  (ArchiveTask)    <248>    EV:M     ConfigureMsgServiceAttempt - Exiting [0x00000000]

 

And able to open message store

398         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:L       {CMailboxHelper::OpenMailbox:#468} Opened message store.

399         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::CreateMapiSession - Get PR_MAILBOX_OWNER_ENTRYID

400         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::CreateMapiSession - OpenEntry(IMailUser)

401         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::CreateMapiSession - Get PR_EMAIL_ADDRESS

402         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::CreateMapiSession - Get IExchangeManageStore interface

403         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::CreateMapiSession - Release Mutex(1)

404         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x0

405         21:34:18.211       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::Initialise - Succeeded in opening privileged MAPI session - closing session

 

BUT MSMQ is not responding correctly.

414         21:34:18.226       [4932]  (ArchiveTask)    <248>    EV:M     {CExchangeVersion::IsExchange2010orAbove}|Is Exchange 2010 or greater: [True]

426         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV~E      Event ID: 3220 Could not detect the MSMQ service.|Error: 0xC00E000B|Check that the MSMQ services are running.  |

427         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:M     Could not Locate the "248" Queue, call returned EVCLUSTERMSMQ\Private$\Enterprise Vault Exchange Mailbox Task for EX 110811170211 A1 |

428         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:H      CAgentTask::Initialise - HRXEX fn trace : Error 0xc00e000b, .\AgentTask.cpp [lines {1452,1459,1468,1480,1484,1485,1488,1489,1492,1494,1614}], built Mar 14 10:54:46 2011.

429         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:M     CAgentTask::Initialise - Com Result [0xC00E000B]

430         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:H      {CAgentTask::Initialise} (Exit) Status: [<0xc00e000b>]

431         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:H      CArchiveAgentTask::Initialise - HRXEX fn trace : Error 0xc00e000b, ..\AgentsCommon\ArchiveAgentTask.cpp [lines {358,364}], built Mar 14 10:54:45 2011.

432         21:34:18.242       [4932]  (ArchiveTask)    <248>    EV:M     CArchiveAgentTask::Initialise - Com Result [0xC00E000B]

 

Please have a look into TN http://www.symantec.com/docs/TECH169549 and troubleshoot on MSMQ component.

 

gilito80mx's picture

tell me where did you get this MSMQ issue? i tray to locate in my trace log, but i did found

Gilberto Lopez

JesusWept3's picture

Just search for "could not locate" there are three instances of it

gilito80mx's picture

apology to you but I put the wrong files, this is the correct file, thank you all again.

here is the real problem.

Gilberto Lopez

JesusWept3's picture

i can't seem to extract the file, sorry, says Unknown Method In File

gilito80mx's picture

here is again the file.

thanks

AttachmentSize
taskFail.zip 4.12 MB

Gilberto Lopez

JesusWept3's picture
MAPI_E_FAILONEPROVIDER 8004011d

<8016> EV:L {CMailboxHelper::OpenMailbox:#291} Opening primary mailbox associated with MAPI session. Getting list of message stores.
<8016> EV:L {CMailboxHelper::OpenMailbox:#299} Reading message store table.
<8016> EV:L {CMailboxHelper::OpenMailbox:#335} Opening message store...
<8016> EV:H {CMailboxHelper::OpenMailbox:#344} Could not open message store: [0x8004011d]
<8016> EV:M {CMAPISession::CreateMapiSession:#445} Releasing exclusive profile lock following error [0x8004011d]

This would suggest its a permissions error.
Can you create a new Outlook profile and connect to COBOGMAIL01 to the system mailbox, SMTP:admin.evault02@Libertycolombia.com

Does it open without prompting for a username and password?
if it does prompt for username and password, then it means the permissions definitely aren't specified correctly.

You may want to try running the Deployment Scanner to see what it says about the permissions to.
It doesnt appear to be an issue with GC or LDAP lookups, but just physically no permission to open the message store objects itself

gilito80mx's picture

hi Jesus, thanks a lot for your help... let me tell you something I try to make the server communication COBOGMAIL01 but this server is behind a balancer that concentrates Exchange2010 3 servers and all traffic going to a single point called "MAIL" I have no way to connect the Outlook direct profile admin.evault02 mailbox on "COBOGMAIL01" think the problem is that internally the task of archive does not reach the Exchange 2010 server? because is no visible for EV?

let me you what do you think.

Thanks

Gilberto Lopez

Advisor's picture

Using any of these CNAME's, are you able to configure affected users profile on EV Server?

Pradeep_Papnai's picture

I would suggest checking the things listed below:

Confirm if the following registry is applied on the EV Server : http://support.microsoft.com/kb/952295 (The recommended registry value is 0xFFFFFFFF)

Confirm Outlook on EV Server is not connecting using RPC Over HTTP

Check if Varonis application installed on CAS : http://www.symantec.com/docs/TECH191097

If EV use any H/W NLB, then please refer to : http://www.symantec.com/docs/TECH146340

 

gilito80mx's picture
I solved the problem in the hosts file adding the alias to avoid first pass through the dns name, and EV resolve itself using the hosts file and do not use the local DNS, I think with that I lose the HA but can not think of another option , any ideas?
 
thank you

Gilberto Lopez

SOLUTION