Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error 8390 The specified archive folder already exists

Created: 28 Nov 2013 | 14 comments

Hello.

I have reoccurring errors 8390:

The EnterpriseVault.DirectoryConnection object reported an error

The specified archive folder already exists

It is followed by an error 6469:

An exception has occurred.

[Internal reference CArchiveAssister/RF/ce]

The two errors alternate and I get at least 100 in a row every night. Below is a fragment of the Backtrack log that shows the error. Has anybody got any ideas?

Thanks.

{CDirectoryConnectionObject::RecreateArchiveFolderV2} HRXEX fn trace : Error [0xc004219b], [.\DirectoryConnectionObject.cpp, lines {15397,15408,15410}, built Sep 12 21:03:57 2012].

202181  21:00:29.506      [6536]  (StorageOnlineOpns)    <9972> EV:L       {CSecurityWrapper::UnloadAzStoreCache:#1742} Unloading authorization store cache from [C:\Program Files (x86)\Enterprise Vault\EvAzStore_Svc.xml]...

202182  21:00:29.506      [6536]  (StorageOnlineOpns)    <9972> EV:L       {CSecurityWrapper::UnloadAzStoreCache:#1742} Unloading authorization store cache from [C:\Program Files (x86)\Enterprise Vault\EvAzStore_Svc.xml]...

202183  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV~E     Event ID: 8390 The EnterpriseVault.DirectoryConnection object reported an error.| |The specified archive folder already exists.| |

202184  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV~E     Event ID: 6469 An exception has occurred.| [Internal reference CArchiveAssister/RF/ce] |

202185  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:L       {CArchiveAssister::CloseDatabase} (Entry)

202186  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:L       {CArchiveAssister::CloseDatabase} (Exit)

202187  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:H      {CArchiveAssister::RecreateFolder} (Exit) Status: [Catastrophic failure  (0x8000ffff)]

202188  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:M     CStorageOnline::RecreateFolder - Failed to recreate ArchiveFolder record [VaultStoreID : 1E58B1C49A067F74B8E3FBE73D54AAF881210000evault  VaultID : 1C77BDB8D7707A94FA6F4CA63123062981110000evault]|

202189  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:H      {CStorageOnline::RecreateFolder} (Exit) Status: [Catastrophic failure  (0x8000ffff)]

202190  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:L       MSTA2 Deallocating busy thread: 6616

202191  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:L       MSTA2 Unlock: 9

Operating Systems:

Comments 14 CommentsJump to latest comment

TonySterling's picture

What version of EV? According to this TN this issue has been addressed in EV 9.0.4 and EV10.0.2

Article URL http://www.symantec.com/docs/TECH204242

A_J's picture

Please share the EV Version ??

A_J's picture

Hello AKtec,

I would suggest to open a case on symantec support as i can see some issue reported and the above article is not exactly related to the issue you are facing.

A_J's picture

Hello Aktec,

Do you have any update to share ??

AKtec's picture

Hi A_J,

I have opened a case with symantec. Last night I sent addtional logs so maybe some time today I will get some info.

A_J's picture

Thanks for the update AKtec..

A_J's picture

Hello Aktec,

Is your issue got resolved ???

AKtec's picture

Hi A_J,

The resolution of this issue has been put on pause as we have another problem we have to resolve before we can continue. As soon as I get some information explaining the problem I will let you know. Currently it is suspected that the problem is caused by certain mailboxes.

TypoProne's picture

Any updates OP? If resolved please update us to relinquish us from any further suspense... and to ensure thaot those who are helping are providing assistnce where it is most needed.

Many thanks.

Anna Bool's picture

Hi,

I exactly the same behavior.

Did someone managed to figure it out?

AKtec's picture

Hi,

Support is still in the process of trying to diagnose the cause of the error. So far we have not been able to capture relevant information using backtrace or dtrace. Running Dtrace seems to freeze the archiving task (A5, A3 queues stops) and the error does not occur until dtrace is turned off.

As soon as the problem is resolved I will let you know.

TypoProne's picture

I have seen similiar errors before that I believe are primarily related to one of two root causes:

1) DB restores that were not taken at the same point in time (either the Directory has records teh VSDB does not or vice versa)

2) someone did a DR and did not update the VSDBs to point to the DR'd copy and did an archive run... so it added records not desired to the VSDB in Prod and not the directory DB in Prod.

Looking at your log are you able to find these records under the root table? The failure seems be be occuring when creating the ArchiveFolder value ... so I may compare the two tables to see if the issues can be identified there as inconsistant data.

202188  21:00:29.521      [6536]  (StorageOnlineOpns)    <6616> EV:M     CStorageOnline::RecreateFolder - Failed to recreate ArchiveFolder record [VaultStoreID : 1E58B1C49A067F74B8E3FBE73D54AAF881210000evault  VaultID : 1C77BDB8D7707A94FA6F4CA63123062981110000evault]|

AKtec's picture

Hello TypoProne,

Sorry for not answering sooner. I have been swamped.

I have been advised by Symantec to update EV as this issue has been fixed in version 10.0.4.

I have not been able to perform the update yet, because we have another problem that arose (DB deadlocks). I was told that I should first fix it before proceeding with the update.

I will let you know how things go after updating))