Video Screencast Help

Error: BaseXmlHttpCallback Exception: System.Exception ... is an invalid character

Created: 11 Sep 2012 | 5 comments
Pascal KOTTE's picture

Module: AtrsHost.exe
Source: Altiris.TaskManagement.ClientTask.*

"11.09.2012 15:43:27","BaseXmlHttpCallback Exception: System.Exception: An exception occurred while executing the request ---> System.Exception: System.Xml.XmlException: '?', hexadecimal value 0x0B, is an invalid character. Line 5688, position 24.

"11.09.2012 15:43:23","BaseXmlHttpCallback Exception: System.Exception: An exception occurred while executing the request ---> System.Exception: System.Xml.XmlException: '?', hexadecimal value 0x03, is an invalid character. Line 5688, position 24.

"11.09.2012 15:43:17","BaseXmlHttpCallback Exception: System.Exception: An exception occurred while executing the request ---> System.Exception: System.Xml.XmlException: '?', hexadecimal value 0x02, is an invalid character. Line 6776, position 25.

Detailed:

BaseXmlHttpCallback Exception: System.Exception: An exception occurred while executing the request ---> System.Exception: System.Xml.XmlException: '?', hexadecimal value 0x0B, is an invalid character. Line 6376, position 24.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ThrowInvalidChar(Int32 pos, Char invChar)
   at System.Xml.XmlTextReaderImpl.ParseText(Int32& startPos, Int32& endPos, Int32& outOrChars)
   at System.Xml.XmlTextReaderImpl.ParseText()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlReader.WriteNode(XmlTextWriter xtw, Boolean defattr)
   at System.Xml.XmlReader.ReadInnerXml()
   at Altiris.DotNetLib.Collections.ParameterValueCollection.FromXml(XmlReader tr, String nodeName)
   at Altiris.TaskManagement.Common.ClientTask.Events.RemoteClientTaskEvent.OnFromXml(XmlReader r)
   at Altiris.TaskManagement.Common.ClientTask.Events.RemoteClientTaskEvent.FromXml(XmlReader r, AltirisResourceGuid resourceGuid)
   at Altiris.ClientTask.Server.ClientTaskServer.ProcessPostClientStatusXml(AltirisResourceGuid resourceGuid, String statusType, XmlTextReader r)
   at Altiris.ClientTask.Server.ClientTaskServer.ProcessPostClientStatusXml(String statusXml)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingServer.ProcessRequestObject(Object work)
   --- End of inner exception stack trace ---
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequestI(String service, Hashtable input)
   at Altiris.DotNetLib.Sockets.SecureRemoting.SecureRemotingClient.SendRequest(String service, Hashtable input)
   at Altiris.ClientTask.Server.HttpHandlers.WebClientApiManager.ProcessPostClientStatus(XmlTextWriter wr, NameValueCollection queryValues, Stream requestStream, Int32 contentLength)
   at Altiris.ClientTask.Server.HttpHandlers.PostStatus.WriteResponse(XmlTextWriter wr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlXmlHttpCallback.WriteResponseRaw(XmlTextWriter xwr)
   at Altiris.TaskManagement.Common.XmlHttp.BaseXmlHttpCallback.ProcessRequest(HttpContext context)","Altiris.TaskManagement.ClientTask.*","w3wp","243"
 

Comments 5 CommentsJump to latest comment

Pascal KOTTE's picture

We got a ton those logs, and I do not find any KB this one, some similar, but not this one:

? I suppose a bad policy or task: but how can I got it ?

I see this one,

http://www.symantec.com/docs/TECH192438

and got also a few of them, but not such a lot the one above, is it related ?

~Pascal @ Kotte.net~ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF

andykn101's picture

Can you see what's coming in in the IIS logs?

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Nonos's picture

It reminds me the problems on the old NS6 when doing a custom inventory and generating a malformed XML using special characters that are not valid in the XML standards.

So maybe some more information about the problem are required to be able to give you an answer or maybe open a case to Symantec...

 

Regards,

 

Cédric DUBIE

Pascal KOTTE's picture

Thanks a lot Cedric, Andy. I think also about a bad custom inventory. I wonder how I can find which one: Well I will deactivate all, and reactivate one by one. BUT: all were deactivated, and still error there.

I will check the IIS logs.

~Pascal @ Kotte.net~ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF

andykn101's picture

Even if all are deactivated there may be nse's still waiting to be delivered from clients.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.