Video Screencast Help

Error code 10 - Allocation failed

Created: 28 Sep 2006 • Updated: 29 Nov 2010 | 2 comments
This issue has been solved. See solution.

We are using NetBackup v5.1 MP 2 in a Solaris environment, in the past week
a backup of one of our Solaris 10 servers has been receiving error code 10 - allocation failed.

We have 2 media servers and each have an ADIC tape lib as their storage units
with SSO (shared) drives. These servers have plenty of CPU and memory so I
don't expect that to be an issue. even when I attempt a backup of the server
in question, with little activity in NetBackup, it fails with error code 10.

I did see mention fo long file lists or file paths as a possible problem, but could
not find the solution.

We use ALL_LOCAL_DRIVES in our backup policy file selection. We do not
have or use NFS mount points.

Note, we've run a separate policy that backups just 2 mount points successfully -
no errors.

Thanks in advance for any help/suggestions you can provide.

Comments 2 CommentsJump to latest comment

Dennis Strom's picture

When studing for the Veritas exams there was a question very much like this and I think the answer is enable multiplexing. I do not quite understand why this would fix it. Unless it is because with so many files the backups are just going to slow for the drives. If you have the advanced client option then flashbackup may help.

Frank Cavadi's picture

I believe I may have found the answer in the following technote:

http://support.veritas.com/docs/273884

There are 2 timeout parameters that can be set:

For Netbackup 4.5 FP3 or MP3 or lower, set in minutes, example -
# echo 30 > /usr/openv/netbackup/binDBMto

Forn Netbackup 4.5 FP4 or MP4 and higher, set in seconds, example -
# echo 1800 > /usr/openv/netbackup/DB_TIMEOUT

There also appears to be a MAX_FILES_PER_ADD taht should be
placed in /usr/openv/netbackup. If not provided, the default for NetBackup
4.5 is 500 and the default for NetBackup 5.x is 5000. Max vaule is 100000.

SOLUTION