Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error code 1042 when trying to activate newly imported layer

Created: 21 Aug 2009 • Updated: 29 Jul 2010 | 4 comments

Has anyone experienced this error before? I have created my SVS packages on a VM, tested and retested. Exported to the DS. Deployed to test machine and while the package imports successfully I cannot activate the package. When trying to activate I get An unexpected error has occured. Error code 1042.

The packages were created in a VM and are now being tested on a new VM...

It doesn't seem to matter if I deply the package or manually import it, the same error is produced.

I am not able to find any error logging in SVS so it is extremely difficult to troubleshoot.

Any Ideas??

Thanks!

Comments 4 CommentsJump to latest comment

Jordan's picture

Error 1042 means that you're trying to activate a layer that is the wrong version.  We've been, rarely, seeing this when you take some layers that were created on 2.1 and imported into a 6.1 machine and do have a fix in place for the next release of SWV.\

Unfortunately there is no workaround for this because the upgrade that's happening between versions is make several changes to the layer.

If a forum post solves your problem please flag is as the solution

matthilt's picture

We've noticed here that we get the issue sometimes even when c

riva11's picture

I have the same error activating layers from SWV 6.1 layers on the SVS 2.1, the error is "An unexpected error has occured. Error code 1042"
But the opposite test works well, layers created on SVS 2.1 then imported and activated succesfully on SWV 6.1.

Here the different versions :

  • Symantec Workspace Virtualization 6.1.4063
  • Altiris Software Virtualization 2.1.2069

Also both versions are running on a clean Virtual Machine.

regards,
Paolo

Jordan's picture

Layer's from SWV 6.1 WILL NOT work in 2.1 just like layers from 2.1 will not work in 2.0.

Most 2.1 layers will run on 6.1 but, as I've stated, there are instances where the layer upgrade doesn't happen so they won't.  There will be a fix for this in the next release of 6.1 and if you want to validate this for us please apply for the customer preview of SP1 as talked about here.

If a forum post solves your problem please flag is as the solution