Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error code

Created: 27 Apr 2013 • Updated: 31 May 2013 | 8 comments
This issue has been solved. See solution.

hello,

I am facing an error of 73 while executing a backup..

+ bpbackup -i -w -p DC1_AIX_BMR_PG136 -s WEEKLY_FULL3M_OFF -k PG136_NCS_BMR.DAILY_FULL_2804 -h PG136
EXIT STATUS 73: bpstart_notify failed
+ RETURE=73
+ [ 73 != 0 ]
+ exit 73
 

can any one guide what is to be done in this case..

as in what I need to check in bpstart_notify script  of client..?

how can I test bpstart_notify script  mannually..?

Operating Systems:

Comments 8 CommentsJump to latest comment

Will Restore's picture

If you are trying to run bpbackup command on the client, do not use -i flag

The -i option of bpbackup starts an immediate manual backup of a client. The

bpbackup option is available only to the administrator on the master server.

on further thought, are you running bpbackup within the bpstart script?  (I hope not)

how about posting your entire bpstart_notify script as text attachment

Will Restore -- where there is a Will there is a way

mph999's picture

Why does the client have a bpstart_notify script, what is it meant to do.

Simply, status 73 means that the bpstart_notify script did not exit with status 0.

Has this ever worked ? or is it a new installation ?

To test the script, you simply run it, you should find it in the netbackup/bin directory.

Be aware that if the script is meant to be on the client, and does something like shutting down a database, you may not wish to run this in the middle of the day ...

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Marianne's picture

Firstly check contents of bpstart_notify script and ask server owner what the script is supposed to do.
Bear in mind that the script runs as root.

You may want to post the script here.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Hannible's picture

the script is running on client..

We are having netbackup 7.1 so the client has bpstart_notify script.

this used to work prior to upgradation from 6.5 to 7.1

below is the bpstart_notify script on Master Server..

# main script starts here
# --------------------------------------------------------------------

umask 022

if [ "$#" -ne 4 ]
then
        exit 1
fi

if [ "$4" = "FULL" -o "$4" = "INCR" -o "$4" = "CINC" ]
then
        OUTF=/usr/openv/netbackup/bin/BPSTART_CALLED

        # You may want to delete the output file elsewhere in order to
        # accumulate successful backup information.
        # If so, comment out the following 4 lines.
        if [ -s $OUTF ]
        then
                /bin/rm -rf $OUTF
        fi

        if [ ! -f $OUTF ]
        then
                touch $OUTF
        fi

        case "$4"
        in
                "FULL")
                        echo `date` full backup started on $1 - policy $2 schedule $3 >> $OUTF
                        ;;
                "INCR")
                        echo `date` differential incremental backup started on $1 - policy $2 schedule $3 >> $OUTF
                        ;;
                "CINC")
                        echo `date` cumulative incremental backup started on $1 - policy $2 schedule $3 >> $OUTF
                        ;;
        esac

        #
        # might want to mail this info to someone
        #
        # cat $OUTF | mail -s "NetBackup backup started" someone_who_cares
        #
        # CAUTION:  some platforms do not allow the -s parameter on mail
        #
fi

exit 0

mph999's picture

We need the script from the client, not the master ...

The script you have posted looks like the default script, which doesn't do anything until it is modified for your requirements.

Many thanks,

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Hannible's picture

Hello I got the below contents of bpstart_notify on Client..

which is same as script on other boxes, however I think there is some process or something that is causin this failure..

PG136# cat bpstart_notify
#!/bin/ksh
#The following line has been removed by Setup:
#/usr/lpp/BareMetal/bmrsavecfg -c $1 -p $2 -s $3 -t $4 > /var/bmr/log/bmrsavecfg.log 2>&1
exit 0

 please suggest..???

CRZ's picture

This is a little bizarre.  Why even run with a startup script at all?  If that's really the entire script....well, everything is commented out except "exit 0" !

The only thing that could possibly cause an error with what you've provided is the event that /bin/ksh no longer exists on the client, which would also be a little weird.

Honestly, maybe just rename/remove this script.  It appears to serve no purpose on this client.


bit.ly/76LBN | APPLBN | 75LBN

Hannible's picture

Hey Guys,

I tried this for above error..

loged on to Client and changed the permissions of  bpstart_notify script  of client.

and backup completed successfully..

Thanks to all

SOLUTION