Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Error Code 48

Created: 07 Nov 2012 • Updated: 18 Jan 2013 | 6 comments
This issue has been solved. See solution.

Backing up SQL instances on active/active cluster, MS SQL 2008.  Netbackup 7.1

Details in Activity Monitor:

11/7/2012 11:12:15 AM - Error bprd(pid=11292) Unable to write progress log </C/ProgramÀ Files/Veritas/NetBackup/Logs/user_ops/mssql/logs/1107112111205-6832-968-000-000-prg> on client UAT-SQL-06. Policy=UAT-SQL-06_FULL Sched=NONE  
11/7/2012 11:12:15 AM - Error bprd(pid=11292) CLIENT UAT-SQL-06  POLICY UAT-SQL-06_FULL  SCHED NONE  EXIT STATUS 48 (client hostname could not be found)

Only information from troubleshooter

The system function gethostbyname() failed to find the client's host name.

Links from http://support.veritas.com/nbucode/48 don't seem to apply or I've already tried it.

Comments 6 CommentsJump to latest comment

CRZ's picture

Okay, obvious questions first:

Has it worked before and only recently stopped working, or has it never worked?

Does `nslookup UAT-SQL-06` return the expected IP address? 

Does `bptestbpcd -client UAT-SQL-06` succeed?

When you're running these commands, are you making sure the hostname is in all capitals, as it is displayed in your log excerpts, just in case that's got something to do with it?


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
HankHill's picture

I'm pretty sure it has worked before and recently stopped, but I don't remember.  However if I try to run a restore, it doesn't find anything for hostname or FQDN.  I have tried the instance name and the server name as the SQL Host

nslookup without FQDN fails, which is strange since I use a hosts file with both in it.  Policy uses FQDN.  Get same error if I switch that to hostname.  IP address in hosts file and in the two commands is the correct IP Address.

 

Marianne's picture

Clustered SQL client - are you using the Virtual name in the Policy and backup script?

You did not tell us if you have tested using bptestbpcd?
Does 'ping' work to client name?

Do you have separate master and media server(s)?
If so, test comms from master and media server(s).

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

HankHill's picture

Using the virtual name everywhere.

Ping works

bptestbpcd appears to return the correct information.

Master is media server for this policy.

 

Happening for all the virtual servers on that server, not just the one. 

captain jack sparrow's picture

Could you give try to flush dns cache and host cache with NBU at both end... Check if this helps..

 Cheers !!!

CJS

 

Marianne's picture

Post is almost 7 weeks old - OP should've resolved it by now...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links