Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Error Code 50 : (client process aborted(50)

Created: 20 Nov 2012 • Updated: 09 Apr 2013 | 8 comments
This issue has been solved. See solution.


For soem of the client backups are failing with the error code 50.

Please find the detials below :

NB Master server :

OS : Windows 2008 R2

NB Version : 7.5

Client :

OS : Windows XP & Windows 2000.

Backups are going directly to the Physical tape library.

Help in resolving this issue.

let me know if need any more information

Discussion Filed Under:

Comments 8 CommentsJump to latest comment

RamNagalla's picture

hi Vamsi,

1) are you getting these failurss every day same time?

2) what is happening if you re-trigger the jobs some other time?

3)  are they regular failurs ?

4) are you taking the backup of all local drives?

and also please provide the bptm , bpbrm and bpbkar logs 

Marianne's picture

What is NBU version on the clients? 

Please show us all the text in Details tab of one of the failed jobs.

Please post clients' bpbkar logs as File attachments. (rename to bpbkar.txt)

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Vamsi-smile's picture

Nagalla, :

Please find the answers below :

1) are you getting these failurss every day same time?

  • Schedule Backups are failing daily

2) what is happening if you re-trigger the jobs some other time?

  • Yes after re triggering also teh backups are failing with same error.

3)  are they regular failurs ?

  • Yes Failing daily

4) are you taking the backup of all local drives?

  • All Local Drives

and also please provide the bptm , bpbrm and bpbkar logs 

AttachmentSize 8.36 KB
Jayaar's picture


Usually an error 50 occurs when the backup of a client is busy running and the media server doing the backup and or client being backup is rebooted or has shutdown. Any such issues in your environment?

RamNagalla's picture

hi Vamsi

see the below errors for acn043vieapp01

there is delay almost 2 hours to have the media server to connect client 

11/19/2012 8:26:59 PM - Info nbjm(pid=8284) started backup (backupid=acn043vieapp01_1353353219) job for client acn043vieapp01, policy win.all.prd.austria, schedule daily.incr on storage unit viewinbkpp001-hcart2-robot-tld-0
11/19/2012 8:26:59 PM - started process bpbrm (3464)
11/19/2012 10:27:02 PM - Info bpbrm(pid=3464) acn043vieapp01 is the host to backup data from     
11/19/2012 10:27:02 PM - Info bpbrm(pid=3464) reading file list from client        
11/19/2012 10:27:02 PM - connecting
11/19/2012 10:27:05 PM - Info bpbrm(pid=3464) starting bpbkar32 on client
bptm is waiting for responce from client to fill the buffers.
11/19/2012 10:28:15 PM - Info bptm(pid=3216) waited for full buffer 111 times, delayed 4068 times    
11/19/2012 10:28:22 PM - Info bptm(pid=3216) EXITING with status 0 <----------        
11/19/2012 10:46:05 PM - Error nbjm(pid=8284) nbrb status: RB deallocated orphaned resources       
11/19/2012 10:46:12 PM - end writing; write time: 00:19:01
client process aborted(50)
bpbkar log:-
10:27:22.079: [2376.792] <2> tar_base::V_vTarMsgW: INF - EXIT STATUS 40: network connection broken
10:27:22.079: [2376.792] <16> dtcp_write: TCP - failure: send socket (736) (TCP 10054: Connection reset by peer)
10:27:22.079: [2376.792] <16> dtcp_write: TCP - failure: attempted to send 48 bytes
10:27:22.079: [2376.792] <4> tar_backup::backup_done_state: INF - Not waiting for server status
10:27:22.094: [2376.792] <16> dtcp_write: TCP - failure: send socket (736) (TCP 10054: Connection reset by peer)
10:27:22.094: [2376.792] <16> dtcp_write: TCP - failure: attempted to send 39 bytes

possibly the reason may be related to

1)Network  or

2) Files that you are included.

these erros most commanly see when its process the files of system state, remove the system state from the backup selection and check the backup for another Drives.

next step would be with the timeout values.

so you can try client read and connect timeout and test backups..

and after that will see the about the buffer tuning..

make only one chage at a time and test the job.. 

Good luck.. let me know if you got something.. 

Mark_Solutions's picture

The Status 50 you show actually ocurrs after the backup completes successfully

This indicates a communication issue between the Client and Media Server and The Master Server

Quite a few of these also appear:

20:10:28.053: [2148.2476] <16> dtcp_write: TCP - failure: send socket (736) (TCP 10054: Connection reset by peer)

20:10:28.053: [2148.3008] <16> dtcp_write: TCP - failure: attempted to send 1 bytes

20:10:28.053: [2148.3008] <16> tar_base::keepaliveThread: INF - keepalive thread abnormal exit :14

Also listed are these:

11/19/2012 10:15:37 PM - Error bpbrm(pid=7520) from client 043-sas01-210d: ERR - Unable to backup System State or Shadow Copy. Please check the state of VSS and associated Writers.INF - EXIT STATUS 69: invalid filelist specification

So .. things to check ...

1. As the clients are Windows 2000 and XP what version of the NBU Client do you use on them

2. If they are an old client are they using VSS or VSP for the open file backups? (Master Server Host Properties - Client Attributes

3. What are the client read and client connect timeout values on the media server (they may need increasing)

4. Does a netstat -a on the Master / Media show a large number of ports in use? If it is a Master/Media Server it may be running out of TCPIP ports to use and hence loss of communication, even internally. If this is the case then do the following:

From an administrative command prompt run:

netsh int ipv4 set dynamicport tcp start=10000 num=50000

This greatly increase the number of TCPIP ports available for a Windows 2008 Server

Also go to:


and add a new  DWORD named TcpTimedWaitDelay with a decimal value of 30 and then reboot the server.

You can do these settings anyway as they will help the system - then try points 1 to 3 above one at a time - Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Vamsi-smile's picture

Thanks for all your reply's. Let me implement and check and get back to you all if any more information needed.

satheesh395's picture


Seems like we are seeing some advanced troubleshooting steps here,

my 2cents of suggestions would be...

1. uninstall and reinstall NBU client ..... (this issue would be happen when there is a corruption in install binaries)

2. try a older version of NBU client - say NBU 7.0 or 6.5 client

3. increase timeout value - default is 300 - increase it to 3000 for testing

4. disable windows open file --> just to avoid any delay caused by VSS

5. reboot the server