Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error deploying project - Copy Files component

Created: 11 Dec 2013 | 2 comments

I am trying to publish a Web Form project in 7.5 (I had completed it in 7.0 and imported to 7.5), but I am getting this error:

Message:

Error deploying project

LogicBase.Framework.BusinessRuleException: Project has validation breaks, please correct

LogicBase.Components.Default.IO.CopyFiles :: Source directory '\\COMPUTERNAME\c$\Folder_Name' does not exist.

  at Symantec.Workflow.Deployment.ProjectBuildEngine.Build()

  at Symantec.Workflow.Deployment.ProjectBuildToZipFile(AbstractOrchestrationProject project, Boolean debug, Boolean inlcudeCustomLibraries)

  at LogicBase.ToolCLI.Actions.DeployProject.LogicBase.ToolCLI.FileAction.Execute(Argument[] args, TextWriter ouptut)

Upon which, I updated the disabled Copy Files component (there is only one) to reflect the new COMPUTERNAME path but then I still got the same error. So I removed the Copy Files altogether, but still same error. I made sure that there was only one "Copy Files" component by going through the browser tab of each model and rebooted server as well. I was able to import and publish my other project just fine. There must be something that I am missing and needs to be updated somehow?

Any suggestions/ideas/thoughts would be much appreciated.

Operating Systems:

Comments 2 CommentsJump to latest comment

reecardo's picture

I'd verify that any source/destination paths used by this Copy Files component exist on the server you're deploying to.

kick's picture

Found the problem... there was another "Copy File" component that I didn't locate. Issue resolved.