Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error Discovery Vault Accelerator

Created: 12 Mar 2013 • Updated: 27 Mar 2013 | 3 comments
This issue has been solved. See solution.

Index search failed :%1 Index :%3 Index: %2

Please see the attachment

I have checked indexing is fine

Comments 3 CommentsJump to latest comment

Kenneth Adams's picture

Greetings, dineshnegi;

The "Index Search failed: %1 Index: %3 Internal reference: %2 (-xc0041c0e)" error typically indicates some issue with the associated index volume where DA could not obtain information it needs to perform the search.  Regardless of the EV version, we can get this error for several different reasons.  Most often, we can resolve this error by optimizing the entire EV environment.  In particular, if you're EV Indexing Server is running on a 32-bit version of Microsoft Windows Server, the PoolUsageMaximum and PagedPoolSize registry values need to be properly set per TECH52776.

From the screen shot, I also see the errors are on 3 different index volumes of the ANS Journal archive.  It could be that those are 32-bit index volumes that are badly fragmented.  If you are running EV 9.x or lower, you can compact those index volumes by locating their physical folders on disk, creating an empty file named 'Compact.task' in each folder, then running the "Update Index Volume" option on each of those volumes.  Note that searches cannot be run against those index volumes while the major compaction is running, but that compaction should only take a few minutes if the index volumes are not very large (i.e, between 2 -3 GB per having the AVSMaxLoc registry value set to 500,000,000 prior to them being built).

If you are running EV 10 and those are 32-bit index volumes, you won't be able to perform the major compaction using the "Update Index Volume" option.  You'll have to actually run a browser search against the archive to kick off the major compaction.  Of course, you could just update the entire archive's indexes to 64-bit and reduce the total number of index volumes in the same action.

Finally, check the search criteria for wild card usage.  Too many wild cards make the search criteria very complex, which can cause the search to not complete on 32-bit index volumes that are badly fragmented.  Just limiting the number of wild cards in the search criteria to, say, 6 or less could allow the search to complete without any other actions taken.

Ken

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

dineshnegi's picture

Hi Adam,

I have tried the TECH52776 few days back after implementing the settings my indexing service get stoped .

 

 

 

Kenneth Adams's picture

Since the recommendations in TECH52776 did not appear to resolve the issue, I recommend opening a Support Case to get help from our EV core folks.  Sorry the recommendations did not resolve the issue for you.  They normally do.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

SOLUTION