Video Screencast Help

Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly.

Created: 15 Jan 2009 • Updated: 21 May 2010 | 21 comments

I will try to make this short:

 

Brand new installadtion of BESR 8.5.1 on a 64-bit Windows 2008 Server (Standard); I'm using the BESR Manager to manage 13 Windows servers, with Windows 2008, 2000 and 2003 "clients.

 

Here's the deal: I have new backups created once a week (Sunday) and recovery points created four times a day; once a day (I'll explain a little later), one of the jobs, on every Windows 2003 server, fails. The Windows 2000 and 2008 Servers always work, but the 2003 jobs will fail 25% of the time. There doesn't seem to be a pattern, a couple of days ago I was backing up at 8am, 11am, 1pm and 5pm; the 8am job would fail (five days in a row), but all the others would work, no problem. So, I removed the 8am job and guess what? Now the 11am job has failed (again, for all Windows 2003 servers) for two days in a row.

 

I just installed BESR- this is not an upgrade for the management server or the clients. I've called Symantec support, didn't get much help. They've said to run checkdisk, defrag, which I have, but I still get this error. They say to stagger the jobs, which I haven't, because I don't see the point; these work 75% of the time and I've monitored the network traffic (this is all being done over a dedicated backup network, not an issue) and that's not the problem.

 

Please help. Thanks!

 

Comments 21 CommentsJump to latest comment

aychekay's picture

I'm curious about a couple things.

 

When you say the backup fails, does it always fail with the error you listed in the subject line?

 

What type of backups are you making, file and folder backups, incremental recovery points, or full recovery points?

 

What media are you backing up to?

 

Would you agree that the pattern that appears to be emerging in your case is this:Server 2003 and first backup job of the day.

Joseph L.'s picture

I have seen this error when there is corruption or install issue with the symsnapservice driver. Try and run the fixinstall.bat on the individual client servers, reboot the servers and allow backups to run

 

 

vincentm's picture

hello joseph,

 

these are production servers and as i said, they're brand new/clean installs (not upgrades) on 8 different servers; it isn't possible for us to reboot these servers very often. i'm a little concerned that an enterprise dr solution may be suffering from "corruption or install issue" on a clean/new install across 8 servers... also, only the 2003 servers are experiencing this- not windows server 2008 or 2000. is there anything else you can suggest? thanks.

 

vincentm's picture

hello,

 

- yes, it's always the same error (please see below).

- i am creating recovery points 3x a day and a full once a week

- backups are to disk (a windows share; the file and share permissions are fine)

- yes, it does appear that it is the first backup of the day. i changed the ms shadow copy provider and volume shadow copy services to "automatic" from "manual" to see if that made a difference, but it didn't. vss admin list writers returns no errors.

 

 

this is the email/notification i get (from this morning):

 

Notification Type: Error
Priority: High
Description: Error EC8F17B7: Cannot create recovery points for job: System Drive (C:\) Backup @ RWC. Error EC8F03ED: Cannot create the recovery point. Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. CHECK failed, Computer::CreateImageFile: .\Computer.cpp(1284): guid != Guid() && sequence != 0xffffffff. Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. %1
Details: 0xEBAB0013

 

it's always this same message.

 

thank you in advance.

 

Joseph L.'s picture

Are you including any utility partitions within the backup jobs? If so, attempt the backups without these utility partitions.

vincentm's picture

any other suggestions here? i have an open case but we're not getting anywhere... thanks.

 

Jon_R's picture

What is your backup schedule? (eg; Monday 1 full, 3 incrementals, Tuesday 4 incrementals, etc.)

dvdb's picture

Same issue on HP Compaq nc6120 with Windows XP SP3. Only 1 disk with 1 C - partition (no utility or hidden partitions)

Symantec Backup Exec System recovery 8.5.1.29666 - First installation

==================================================

 

- First backup for "Recovery Point Set".  

Start with "Creating recovery point" - Initializing

After 20 sec - Drive backup starts 0%

Immediately Error 

Cannot create the recovery point.

--Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. CHECK failed, Computer::CreateImageFile: .\Computer.cpp(1284): guid != Guid() && sequence != 0xffffffff.

 

Reboots, System Updates, Repair of System Recovery --> same problem

 

- Backup "Independent recovery point"

Start with "Creating recovery point" - Initializing

Creating new image file

---------------------------
Drive Backup of  (C:\) (2)
---------------------------
This operation cannot be performed while Windows is running.
You must complete this operation inside the recovery environment.

Would you like to continue?
---------------------------
Yes   No  
---------------------------

Error EC8F17B7: Cannot create recovery points for job: Drive Backup of  (C:\) (2). Error E0BB001B: Cannot lock volume C:\ because it contains the OS or has an active paging file. Error EBAB03F1: The volume contains system or paging files.
Details:
Source: Backup Exec System Recovery

 

No idea what can cause this problem, but seems to be similar like the one on the servers in this thread.

 

Yoann's picture

Hello

I was using BESR 6.5 to backup workstations to extral drives

and it  was workingnice ...

I upgraded to 8.52 ( Symantec send me an free upgrade for my licences )

since this day I can't backup the System drive c:, I have this error

 

-Impossible de créer le point de récupération.
--Erreur EBAB0013 : Échec inattendu d'un test préservant l'intégrité du programme. CHECK failed, Computer::CreateImageFile: .\Computer.cpp(1284): guid != Guid() && sequence != 0xffffffff.
 

don't know why, as it was working with the old version

i plan to go back to version 7 or 6

 

Chris Riley's picture

If you look in services, do you see the following?

 

Symantec SymSnap VSS Provider

SymSnapService

dvdb's picture

I couldn't uninstall the application --> PC hangs during uninstall of 8.5.1

 

From Symantec support, received uninstall script + installed new version and problem was solved (also removed links to BSR in all users profile and on USB disk (folder with image and a hidden folder)

 

At this point I would recommend running the uninstall script to remove BESR.  http://seer.entsupport.symantec.com/docs/309169.htm Run the script then reboot.  After removed, download BESR 8.5.2 from the FileConnect site and install http://seer.entsupport.symantec.com/docs/300437.htm

 

breb02@yahoo.com's picture

I had the same problem (Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly.....<and all the rest>) on a Win 2003 Server environment.
On some of the servers the installation went perfectly...no errors, no problems backing up the hard drives.
On others...the installation hanged up just before finish (on status it was saying "Installing ..")
   What i did first ... I killed the process, reboot the server, put the license key, schedule the job, run it ... and then is when I got the ERROR
  After that I've uninstalled, reboot, start the installation again, and at the moment it hanged up I opened a Task Manager window and killed all msiexec processes (I had 5 of them) ... then kill the BESR installation process ... start the installation again and this time work without hanging up.

 Reboot the server and everything worked as it was suppose to.

 Stupid and silly solution to the problem ... but it worked.

Symanticus's picture

Yes, it happens to me when i back up my Exchange Server 2007 into another fileserver location using mapped network drive (in this case drive B:\)

-Cannot create the recovery point.
--Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. CHECK failed, Computer::CreateImageFile: .\Computer.cpp(1284): guid != Guid() && sequence != 0xffffffff.

but still not sure how could that be happening ?

/* Infrastructure Support Engineer */

bbusch's picture

I am also receiving the same error as mention above, the "test that safegaurds the integrity of the program....".  It is on a Windows 2003 Server, and I am backing up partitions C: and E: in the backup job.  I saw someone mention partitions above, could that have something to do with the issue?

Thanks
Brandon
 

Quan Duong's picture

My DC runing WIndows 2008, the backup working fine version 8.5. I just update to newer version 8.5.5 and then I got the error:

rror EC8F17B7: Cannot create recovery points for job: Drive Backup of  (C:\). Error EC8F03ED: Cannot create the recovery point. Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. CHECK failed, Computer::CreateImageFile: .\Computer.cpp(1284): guid != Guid() && sequence != 0xffffffff. Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. %1

Have any idea?

Chris Riley's picture

Quan Duong:

Is it ONLY incremental backups that fail with this error?

Quan Duong's picture

No, It the very first Full backup right after installation and all liveupdate.
Do you have any idea?

Thanks

Vyasa's picture

Hi,

I've just reinstalled Ghost 14 because my recent installation of Norton 360 did something to make my previous installation of Ghost 14 inaccessible.  Over the last 2 days I have tried to do a simple one-time backup of my internal drive to a USB connected external drive.  Both attempts have terminated after 5-6 hours with:

Error EC8F17B7: Cannot create recovery points for job: Drive Backup of HP_PAVILION (C:\). Error EBAB0013: A test that safeguards the integrity of the program failed unexpectedly. CHECK failed, BaseProcess::ThreadPool::UnreserveThread: .\ThreadPool.cpp(411): mPoolData->mWorkUnits [index].status == UnitOfWork::RESERVED.
Details: 0xEBAB0013
Source: Norton Ghost

Both the source and destination disks were preped with chkdsk and defrag, and I have had several successful backups with my previous installation of Norton Ghost 14.  As a consequence, I have been searching for an interpretation of the diagnostic that would help me get a successful backup before I waste another 5 hours.  All I have been able to find is that others, with much more complex systems that I have, have had problems that generated the same diagnostic.

I don't know that the diagnostic is a meaningful clue to the problem I'm having with Ghost, but I thought I might be able to find a dictionary of diagnostics on Symantec's website, and then, assuming that it was helpful, be able to help myself.

I would appreciate any assistance with either the problem or the dictionary of error codes.

Thank you

djkiff's picture

I had the same issue on 3 of my Windows 2003 servers when I upgraded to BESR 8.5.5. I am using the BESRM to manage my backups
I did the whole uninstall, reinstall several times to try and fix it and finally found this article at Symantec Enterprice support:
Document ID: 311728

Backups Created by Backup Exec System Recovery Manager Fail with Errors; "EC8F17B7 Cannot create recovery points for job, EC8F03ED Cannot create the recovery point, EBAB0013 A test that safeguards the integrity of the program failed unexpectedly"
 
Details:
Cause:
 
Backups created with Backup Exec System Recovery Manager with "All Mounted Drives on Selected Computers" selected as the drives to be backed up. The computer(s) have an OEM recovery partition.
 
Solution:
 
Update the software to the latest build (8.5.5 or later). This should resolve the problem. If the behavior persists, create a new backup job

When I switched to just backing up the C:\ drive it finally worked.

David Kiff - AAC, MCSE