Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error enabling mailboxes.

Created: 27 Jun 2013 • Updated: 30 Jun 2013 | 6 comments
This issue has been solved. See solution.

I have an issue trying to enable mailboxes on an EV 9 server. I get Event ID Event ID: 3139 An non-specific error has occurred whilst enabling archiving for the mailbox which is similiar to other posts I have come across however the error is a bit different in that it is 0x80040605.

The Outlook profiles for the VSA and the archiving task mailboxes are all fine. I have cleared out the temporary MAPI profiles but that hasn't helped.

I ran a DTrace on the AgentClientBroker task and found the following:

[7532] (AgentClientBroker) <5596> EV:M CMAPISession::GetMapiSessionFromPoolEx: Exit status: 0x80040605

I have run the provisioning task in case the mailboxes were failed over to another Exchange node (the servers are Exchange 2010) as that sometimes happens but that doesn't appear to be the case.

Thanks in advance.

Operating Systems:

Comments 6 CommentsJump to latest comment

TonySterling's picture

Do you seen any other erros?

I am pretty sure that error means:

MAPI_E_NOT_INITIALIZED

Also, is everything ok with the system mailbox?

AlanJ's picture

There were some Event ID 3411 errors contacting the GC that were logged early this morning which has been sorted now, but apart from that everything looks fine.Yesterday there were no other errors being logged when I first tried to enable mailboxes.  The system mailboxis fine, I am able to open up the Outlook profile for it.

VirgilDobos's picture

Hi Alan,

To me it seems to be indeed related to some MAPI problems. Try restarting the EV services/Task Controller and attempt enabling the mailbox again.

If problem persists, try with some different mailboxes. Getting the same error? If so, ensure the Deployment Scanner comes clean.

Cheers,

Virgil

Virgil Dobos | Sr. Technical Consultant | Condo-Protego | www.condoprotego.com 

SOLUTION
AlanJ's picture

Hi Virgil,

Deployment scanner comes back clean. There is a scheduled task that restarts the services but the issue still persists.

Mailboxes have been failed over to the DR server, tried those servers and get the same result.

 

Cheers,

Alan

AlanJ's picture

Had an issue with the service restart task which didn't run as expected. Once services were restarted, mailboxes have been enabled.

VirgilDobos's picture

Good to hear you got it sorted out. Cheers! :)

Virgil Dobos | Sr. Technical Consultant | Condo-Protego | www.condoprotego.com