Video Screencast Help

Error with the EV Health Status reports, SQL2008 R2.

Created: 11 Oct 2010 • Updated: 12 Oct 2010 | 1 comment
FreKac2's picture
This issue has been solved. See solution.

Hi all,

I've deployed the reports to a dedicated EV SQL server running SQL 2008 R2 Standard (x64).

The deployment was successfull except the "lack of an audit database" error, so no "real" error per say.

I can run e.g. the SIS reports but the 7 day / 24hr health reports produce an error (same error), I made a trace of it (on the sql server) and I get the following:

277 14:37:59.260  [4840] (ReportingServicesService) <2228> EV-M {JobList.GetDataSet} Entered JobList::GetJobDetailsDataset()
278 14:37:59.260  [4840] (ReportingServicesService) <2228> EV-M {JobList.GetDataSet} Leaving JobList::GetJobDetailsDataset()
279 14:37:59.262  [4840] (ReportingServicesService) <2228> EV-M {RuntimeDataSet.RunEmbeddedQuery} Exception: Could not load file or assembly 'KVS.EnterpriseVault.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=26c5e2ccf2b9267c' or one of its dependencies. An attempt was made to load a program with an incorrect format. Info: Diag: Type:System.BadImageFormatException ST:   at Symantec.EnterpriseVault.Reports.EVReports.StatusTrending.GetServiceName(Int32 serviceTypeParam, String langIDParam)|   at Symantec.EnterpriseVault.Reports.EVReports.JobList.GetDataSet(String connectionString, ArrayList parameterCollection)|   at Symantec.EnterpriseVault.Reports.DataProcessing.EVReportCommand.ExecuteReader()
280 14:37:59.265  [4840] (ReportingServicesService) <2228> EV-L {DataExtensionConnectionBase.CloseConnection} Entered EVReportConnection::Close()

Monitoring is enabled on the evserver, I've verified that the EnterpriseVaultMonitoring DB contain data in tables.

I've also run forcemonitoringutil.exe just to verify that EV can update the database.

The only reference that I've found to a similar problem is when using a x64 server with the e.g. unsupported 32bit reports.

But I've not found any reference to the same problem when using 2008 R2 x64 and the health reports.

So any hints on how to troubleshoot/fix this ?

 

Cheers

Fredrik
 

Comments 1 CommentJump to latest comment

FreKac2's picture

I'll "answer" this myself, apparently they don't work at the moment.

It's stated in the readme but apparently nowhere else :)

Anyway, here is a link to the discussion were I found the answer.

https://www-secure.symantec.com/connect/forums/ev-90-and-sql-2008

 

 

Cheers

Fredrik

SOLUTION