Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Error Extracting Files From XPF Archive

Created: 19 May 2014 | 5 comments

Hi, I'm trying to import a new application onto a x86 test PC and I'm seeing the error:

Error Extracting Files From XPF Archive

I've looked through the information on this site, but cannot find any information on it. I have tried using both the Admin console and command line tool - but no joy. The command line gives the following error:

Error: 1010
SVSCMD failed: IMPORT

I am running the following version: SVSCMD: 7.5.538

Has anyone seen this error before?

The package was created on a Win7 x86 PC and I re-packaged it 3 times, all giving the same final result. The software I am packaging is VMware Horizon 2.3.3. I tested v1.0 of the package and it worked fine, but the connection server changed so I had to re-do it. The error is appearing on v2.0 and I get it on 2 separate test PCs. I'm not aware of anything which has changed and the process was the same as I did with v1.0.

Lee

Operating Systems:

Comments 5 CommentsJump to latest comment

LeeC1010's picture

It looks like this is now resolved. I was battling for 3 days over this, but it turned out to be a simple thing.

We virtualised Silverlight and when the layer was active it would stop other XPF files from being imported. We'll have to re-visit the Silverlight installation and find out what could be causing this.

It just shows how active applications can affect other applications!

LeeC1010's picture

Just to follow up on this.

Further testing showed that the problem with the Silverlight package was because of the priority being increased. I'm still looking at at which point the issue occurs and if there is a reason.

EdT's picture

Thanks for posting updates - this will undoubtedly help others.

However, it does point up the risks associated with different packages which may offer the same file associations. With the older non virtual packaging tools you could run conflict management and this aspect may still be helpful when dealing with virtual packages.  As a matter of interest, do you use any tools such as Wise Package Studio or InstallShield Adminstudio in house?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

LeeC1010's picture

No I think we used to have Wise and maybe it is on an old PC somewhere, but we're not using it day-to-day.

Does Wise have a conflict management function builtin?

EdT's picture

Wise Package Studio does, but in a virtual environment, file conflict management is not really important and it's really only file associations that are of any interest, at least in my experience. Depending on the virtualisation tool you are using, two virtual apps capturing the same file association can be managed so that one always gets priority over another, but of course you can still add the "right click" shell associations so that you can open a specific file with your choice of app(s).

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.