Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

ERROR IT Analytics connections to SEP databases

Created: 30 Jan 2014 • Updated: 06 Mar 2014 | 8 comments
This issue has been solved. See solution.

hello,

I get an error when the conexion with SEP:

Exception: Statement(s) could not be prepared. Invalid column name 'IP_ADDR_TEXT'. OLE DB provider "SQLNCLI10" for linked server "ITANALYTICS_SEP_SYMANTEC_CMDB_FOS-3SI-SECT\SEP_SEP " returned message "Deferred prepare could not be completed.".

 

Thanks

 

Operating Systems:

Comments 8 CommentsJump to latest comment

SK's picture

Review this article which mentions the same invalid column error as it may point you in the right direction:_ 

https://www-secure.symantec.com/connect/forums/110...

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

David.Balsa's picture

hello,

I can not find where is the error column,

I just configure Sep11 with altiris IT Analityc 7.5.
in the menu

sep.JPG
David.Balsa's picture

hello,

 

I applied the script for the following http://www.symantec.com/docs/TECH211381

and now I have this error:

Exception:Statement(s) could not be prepared. Invalid column name 'DELETED'. OLE DB provider "SQLNCLI10" for linked server "ITANALYTICS_SEP_SYMANTEC_CMDB_FOS-3SI-SECT\SEP_SEP" returned message "Deferred prepare could not be completed.".

 

 

LOG:

Exception updating SEP dependencies

System.Data.SqlClient.SqlException (.Net SqlClient Data Provider): Statement(s) could not be prepared.

Invalid column name 'DELETED'.

OLE DB provider "SQLNCLI10" for linked server "ITANALYTICS_SEP_SYMANTEC_CMDB_FOS-3SI-SECT\SEP_SEP" returned message "Deferred prepare could not be completed.".

at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)

at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)

at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)

at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)

at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)

at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)

at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)

at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()

at Altiris.ITAnalyticsSEP.Tasks.SEPUpdateDependenciesTask.ProcessTasks()

SQL Exception details: code=8180, line=1

Exception logged from:

at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception, String footer)

at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)

at Altiris.ITAnalyticsSEP.Tasks.SEPUpdateDependenciesTask.ProcessTasks()

at Altiris.ITAnalyticsSEP.Tasks.SEPUpdateDependenciesTask.OnExecuteTask(Hashtable taskArgs)

at Altiris.NS.StandardItems.Tasks.BaseItemTask.ExecuteTask(Hashtable taskArgs, ItemTaskState state)

at Altiris.NS.ItemTaskManagement.ItemTaskThread.LaunchTask()

at System.Threading.ExecutionContext.runTryCode(Object userData)

at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)

at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

at System.Threading.ThreadHelper.ThreadStart()

**CEDUrlStart** :http://entced.symantec.com/entt?product=SMP&version=7.5.1670.0&language=fr&module=z2XPUchvpC1e9I1cd8HnExxxtpAho3mX72jxyI/RcJD5JgqUSufWTbNwB6J9FtUPFOKS3xTK5e2pyQXqVMclDQ==&error=-1021371503&build=**CEDUrlEnd**

ArisZ's picture

Hi,

Since the script you applied appears to be for SEP version 12.1.2 that explains why the column it's looking for changes in the error. You can try going into the Symantec Installation Manager and uninstall / reinstall the IT Analytics SEP report pack for version 11 this should replace the script back to the correct version. Show all available versions will need to be checked and the 7.1sp2 would be the SEP 11 pack.

sepCapture.PNG

 

SOLUTION
David.Balsa's picture

thank you

Version 7.5 is compatible with SEP12.

passing 7.1 connection is made ​​with Sep11.

Artur S.'s picture

Hi,

 

I'm geting the same error!?

But I'm using SEP12.1.4 and I have installed Altiris IT Analytics 7.5 and Altiris IT Analytics Symantec Endpoint Protection Pack 12.1.4

I tried to reinstall the IT Analytics pack but no difference...

I have not run the script in TECH211381 since it says that this issue should be fixed after IT Analytics 7.1 SP2 and IT Analytics for SEP 12.1.2

I think that our SEP 12.1.4 was an update from a SEP11 but im not sure... I do know that I don't want to do a DR on SEP if at all possible...

So I'm kinda stuck here... any good idea's?

Artur S.'s picture

Hi again...

Well it turned out that the sem5 database that I was trying to connect to was an old SEP11.x database!?!

IT Analytics 7.5 does not work with SEP11.

After i found the correct database everthing went as it should... so remember to check in SEPM before assuming that the sem5 database in front of you is the correct one ;-)

http://www.symantec.com/docs/TECH168570