Video Screencast Help

error occurred while connecting to the Agent

Created: 28 Nov 2013 • Updated: 02 Dec 2013 | 6 comments
This issue has been solved. See solution.


i just upgraded to "Backup Exec 2012 sp3" and i'm receiving the following error.:

The job failed with the following error: The resource could not be backed up because an error occurred while connecting to the Agent for Windows. The correct version of the Agent for Windows must be running on the target computer. 

I found out if i add the server with the FQDN  then it fails, but if i don't it works. 
i can browse and more on the server created with the FQDN so i'm a bit puzzled.
Do any of you, have any idea? (tech support are lost for a solution at the moment (it should work 100% when it is with the FQDN.))
Ps. forgot to mention:
I pushed the Agent from the server -->reboot -->(no change)
I uninstalled-->reinstalled the Agent   --> reboot -->(no change)
i repaired the Agent --> reboot -->(no change)
Operating Systems:

Comments 6 CommentsJump to latest comment

RahulG's picture

Can you get the enable logging for the remote agent and Beengine ?

I assume are able to ping the server using FQDN name and there is not DNS issue . Can check if you have added the FQDN on the publishing tab of the remote agent utility.

Emort's picture

How do i "enable logging"?

Ping is fine with and without FQDN, and there is no DNS issue.

Under the "publishing tab" both backupserver field and the "Published names for this agent:" is with the FQDN.
Gurvinder Rait's picture

Can you add entries of the server you are backing up uing FQSN in media server hosts file.

Emort's picture

I added the FQDN to the media servers host file, rebooted sadly it still doesn't work?

any other ideas?

Emort's picture

can recreate the server entry without the FQDN or do i need to create new server entries ?

Emort's picture

tech Support closed the case with might be fixed in 2014...