Video Screencast Help

Error Opening Projects Due to Missing Object Type Definitions

Created: 15 May 2014 • Updated: 15 May 2014 | 1 comment
This issue has been solved. See solution.

After working to redefine an Integration project, specifically a User Defined type with DB Mapping generator, I found that many of my existing projects would no longer open without throwing Project Open Errors.  I'm getting a series of messages such as:

Cannot read value 'data Type' of type 'System.Type'

or

Cannot find type 'GetSOD_TitilesWithLicenseCounts.SqlQuery.GetSOD_TitlesWithLicenseCounts'

The second message refers to a user defined object.

Please see the attached document for more examples.

Can anyone imagine what I must have done to loose access to these object type definitions and suggest a resolution?

The problem is widespread but does not affect all of my projects.

Operating Systems:

Comments 1 CommentJump to latest comment

M Rutledge's picture

I found my problem.

I had copied the Package file of an Integration project to my 'Sandbox' directory to try and resolve an existing issue with one of its generators.  Once I opened the Integration project in the Sandbox directory I deleted all of the existing generators except the one I wanted to work with.  After recompiling the Sandbox version of the Integration project all references to the deleted generators threw the errors I was seeing.  This happened even though they still existed in the original Integration project. 

It's as if changes to the copied version of the Integration project were impacting the original version.

I guess my shortcut, of copying the Integration project to another folder rather than building a new one, was a bad idea.

I resolved the errors by recompiling the original Integration project and resetting IIS.

SOLUTION