Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error restoring email items from GRT backup on Exchange 2010

Created: 11 Sep 2013 • Updated: 16 Sep 2013 | 11 comments
Eyal Gross's picture
This issue has been solved. See solution.

Hi,

I'm trying to restore specific emails from a GRT backup (from tape). I'm restoring to the original mailbox, no redirect.

I'm getting an error:

"Unable to restore any content for Ami Levin [ibp1435] because the Microsoft Exchange database that hosts that mailbox is offline or the mailbox doesn't exist.

Cannot restore one or more mailboxes. The database that the mailboxes reside in is dismounted or is not accessible. Ensure that the server is available and that the database is mounted, and then run the job again."

I have already managed to succesfully restore other items for another user with no problem. only difference is that it was from B2D and not from tape.

I also tried to redirect it to another mailbox but same error.

I read about getting this error if there are [ ] in the mailbox display name, but this is not the case. The display name is Ami Levin.

 

Any idea wha could be the problem?

 

Operating Systems:

Comments 11 CommentsJump to latest comment

Donald Eady's picture

Try duplicating the backup set from tape to disk and reruninng the restore job from the disk location.

Additionally you may want to verify that all permissions/rights for the service account mailbox are still as they should be.. and that the mailbox is till active an unhidden from the GAL... See document below

 

http://www.symantec.com/docs/TECH184449

I hope this posting was helpful

  

VipulK's picture

Hi,

Please verify that the System Logon Account is used to run the restore and has correct permissions as per tech note:

http://www.symantec.com/business/support/index?page=content&id=TECH130255#Exchange_Agent

Duplicating the backup set to disk, would be a step that you can try to get away with the staging time that you have to wait for when restoring from tape.

 

Regards..

Eyal Gross's picture

Hi,

The job runs with the system logon account credentials and I used the "Test" button to check it and it was successfull.

Also the logon account is active, and member of everything it should be according to the link Symantec.

The mailbox itself is also active and working fine and is not hidden from the GAL.

I also tried redirecting to another working mailbox and same results.

Funny thing is I just ran a restore two weeks ago for another mailbox the exact same way and it worked fine.

I understand that duplicating the job to disk is just to resolve the restore time issue?

any other ideas?

Eyal Gross's picture

By the way, I have two B2D devices (folders) - one for regular backups and one for GRT backups.

Since this is an Exchange  GRT backup, if I'm duplicating this backup set from tape to disk, do I need to use my B2D device or B2D-GRT device?

 

pkh's picture

It makes no difference which B2D folder that you use.

Eyal Gross's picture

OK,

I duplicated the backup set from the tape to disk and it finished successfuly.

I created a new restore job, started to expand the tree in the selection window and as I try to expand the "Database" folder the program freezes. Tried that several times and same result.

Any thoughts?

Eyal Gross's picture

Hi guys,

some updates:

I tried restoring email messages from different mailboxes, from different folders inside these mailboxes, tried redirecting to other mailboxes and tried restoring from different medias and backupsets.

Every time I get the same error:

"Unable to restore any content for mailbox name [username] because the Microsoft Exchange database that hosts that mailbox is offline or the mailbox doesn't exist."

I don't recall changing any setting on the Exchange server itself.

What can be the problem?

Eyal Gross's picture

So, Finally a solution! :)

I opened a support case and it turns out there have been lots of other security and permission missing for the logon account, as per this article:

http://www.symantec.com/business/support/index?page=content&id=TECH184449

Espessialy regarding paragraph 2.

After that the restore was succesfull.

Thanks everyone for the help.

 

SOLUTION
Donald Eady's picture

LOL... I suspected as much... "this is why i provided this article to you in my first post" *wink *wink... Im glad to hear that the issue was resolved.. .Please dont hesitate to post with any questions you may have in the future.. 

I hope this posting was helpful

  

Eyal Gross's picture

You're absolutly right!

I don't know how but for some reason I skipped the link you posted and only checked the link that Vipur supplied.

Can I correct it and mark your post as the solution instead of mine?

Donald Eady's picture

Eyal Gross smiley

 

 No need to i was just giving you a little grief..wink Joking aside im pleased to hear that you found the solution to the issue...  and absolutely nothing else need be done on your part.. 

I hope this posting was helpful