Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Error in SEPM Upgrade from 11.06 MP3 to 11.07 MP1 with embedded db

Created: 03 Nov 2011 | 2 comments

I just tried to upgrade our SEPM server from 11.06 MP3 to 11.7 MP1 and the database upgrade failed.

We are using the embedded database moved to a seperate drive on a Windows 2008 R2 server.

It seems like the update script resets the connection string in registry

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\ASANYs_sem5\Parameters]

the Parameters value is reset back to default wich expects to find the database under C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\db\

 

My solution to this was to move the database files back to the default location and run the upgrade again. When the upgrade is complete I moved the database back to the drive where I store the database. Adjust the registry and the ODBC connection with C:\Windows\SysWOW64\odbcad32.exe

Comments 2 CommentsJump to latest comment

Chetan Savade's picture

Hi,

You are correct, it may applicable for SEP 11.x to SEP 12.1 upgrade also.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<