Video Screencast Help

Error setting up AD Sync and Login - Servicedesk 7.5

Created: 05 Feb 2013 • Updated: 26 Aug 2013 | 8 comments
This issue has been solved. See solution.

I uninstalled 7.1 sp2 off a server then did an install of 7.5.1 to the same server but now i am having trouble with ad sync.  Said can not find some net bios component. "CheckAndResolveDomainName - general error getting netbios domain name System.DirectoryServices.DirectoryServicesCOMException (0x80072030): There is no such object on the server."  I assome I have some old service desk part giving me trouble.  does anyone have a set of uninstall and clean instructions.  for uninstall and reinstall.

Comments 8 CommentsJump to latest comment

reecardo's picture

Can you verify that you are in fact not using the ServiceDesk beta? This was a problem in the beta but was fixed later.

Kevin Shilling's picture

I did update the server SIM to the 7.5 version right before the install on the SMP/NS.

gBBB's picture

Hi Kevin,

To me it doesn't look like this is a problem with an incomplete install. Rather, I think it's related to the AD Connection Profile information you are using. Some changes were made to the workflow build that underlies ServiceDesk 7.5 regarding AD Connection Profiles, and this may be complicating the issue.

If you open the Credentials Manager, and edit your AD Connection Profile, what are you using for the Domain Controller and domain fields? The Domain Controller field is new to 7.5, and must resolve correctly for AD Sync to work. It was added to allow customers to specify which DC to connect to if there are multiple DCs in a certain environment.

When you've entered your Domain Controller, Domain, Username, and Password - Credentials Manager will automatically run a connection test. Does this pass, or do you see the same error here? If you get an error, try using a different method for addressing the Domain Controller or Domain (fqdn, IP address, etc). The specific error you got is a common .NET error, and I found several instances online where users resolved it by using a different method to address their domain ( for example)

Hopefully that helps you resolve the issue. If it doesn't, give us a little more detail on your Connection Profile and we'll see if we get diagnose it further.

Good luck!

Kevin Shilling's picture

It started working after putting the Fully qualified domain name of domain controller in "domain controller" and "domain" field.

still cant auto authinticate though, but ad sync for users did go through.

TGiles's picture

When you create the AD Profile in the portal what is appearing as your Domain Name? If this is showing your fully qualified name & not the netbios name of your domain it is more then likely what is causing your problem.

This will cause the AD Name information stored in the database to appears as FQDN\Username and not NetBiosName\Username.

Kevin Shilling's picture

It appears as NetBiosName\Username if i change it to FQDN\Username it allow login just fine.

TGiles's picture

Okay, so IE is passing the credentials to PM as FQDN\Username instead of the Netbiosname\Username which we are getting saved into the database.