Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

error with SmeUtil.sys - Ghost Solution Suite 11.5.1.2266

Created: 19 Nov 2012 | 5 comments

Hello,

 

I'm having a problem with Deploy Anywhere after creating a WinPE 3.0 boot disk including Ghost executables.  Everything is working fine with exception to Deploy Anywhere, it's throwing an error:

 

"Unable to connect to the SmeUtil driver.  The handle is invalid."

 

I followed this guide for adding Ghost executables to WinPE 3.0:

http://www.symantec.com/docs/TECH194877

 

The guide does not mention Deploy Anywhere under WinPE 3.0, but instead just covers getting Ghost32 working, with driver support.

 

I have tried all combinations to include the SmeUtil.sys driver in "windows\system32", as is required.  Many posts I have read refer to this again and again.  No matter what I do I get the same error.  Whether packaged into the .wim, or added to system32 manually after booting up, no success.

 

Does anyone have any tips for what I could try next?  I plan to stay very active on this thread and will try anything anyone recommends.

 

Here's a screenshot to get things started...

http://i.imgur.com/SaJTh.jpg

*Please note, in the screenshot I do not specify a driver database.  This is intended.  Whether I specify a driver database or not, I get the same error.

 

Thanks everyone for taking the time to help me out with this.

Comments 5 CommentsJump to latest comment

EdT's picture

GSS 11.5.1.2266 has not been validated against WinPE 3.0, so it is difficult to know whether your issue is caused by the version of WinPE you are using, or some other factor.  Try searching this forum on "smeutil.sys" and see whether any of the past discussions are relevant. For example, the file should be present in the windows\system32\drivers folder and not in system32.

Have you tried with WinPE 2.0 ?  If that works, you could compare the actual filesets present on the WinPE booted image with the 3.0 version to see if all files are present and in the right location.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Ysosrs's picture

Thank you for your response. 

 

Deploy Anywhere works great with WinPE 2.0 when creating a boot disk via Ghost Boot Wizard.  My problem is newer systems we have arriving will not boot to WinPE 2.0, these are the newer UEFI equipped systems.  They require WinPE 3.0 to boot without bluescreening on me.  If we need to retarget an OS to different hardware, and WinPE 3.0 is required, we're out of luck as far as Deploy Anywhere is concerned. 

 

Are there alternatives that will evaluate your hard disk controller(at the very least), and allow injection of the proper proper driver, thus allowing it to boot?

 

Further, I've scoured all over the net regarding this SmeUtil problem.  All of the posts are telling me "windows\system32" for the location of "SmeUtil.sys", which I've tried with no success.  I'll try "windows\system32\drivers" as per your example, just for the hell of it.  I'm willing to try anything at this point.

 

I've double checked all paths for Ghost executables and SmeUtil.sys, everything looks proper and everything functions just fine ... except for Deploy Anywhere.

 

Looking forward to any additional information from further posts.

 

Thanks again,

Ysosrs's picture

Sadly no luck.  I've placed SmeUtil.sys (by mounting the wim and copying) in the following locations and still getting the error..

 

X:\Ghost

X:\Windows

X:\Windows\System32

X:\Windows\System32\Drivers

Ysosrs's picture

Is there perhaps a newer product by Symantec that will do what I am proposing?

 

If there were I would purchase it.

 

Please respond Symantec reps :)

EdT's picture

There has been talk of a newer version of Ghost being released at some point, but that talk appears to be vaporware as months on, no date is even hinted at.

The Altiris deployment server product (or whatever Symantec call it these days) does offer Ghost functionality within its deployment services and I believe this product is more up to date.

You don't mention what operating system you are trying to deploy, but if it's Win 7, the Microsoft Windows Automated Installation Kit is pretty straightforward to use, and since driver library management is much better in Win 7 than in XP, it's so much easier to add drivers without needing something like Deploy Anywhere.

Whichever way you go, there is going to be a learning curve, and the Microsoft stuff is free to download.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.