Video Screencast Help

Error upgrading DA

Created: 30 Nov 2013 • Updated: 04 Dec 2013 | 8 comments
This issue has been solved. See solution.

Any suggestions on what I should do if I get this error when I try ot upgrade a database?

 

DELETE failed because the following SET options have incorrect settings: 'ANSI_PADDING'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods.
DELETE failed because the following SET options have incorrect settings: 'ANSI_PADDING'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or query notifications and/or xml data type methods.
DELETE failed.
 
Other databases upgraded sucessfully, I only have 2 out of 7 that are like this.
 
 
I verified that 'ANSI_PADDING' is off for all databases.
 
Thanks.
 

Comments 8 CommentsJump to latest comment

TonySterling's picture

What version of DA and are these customer databases?

Also, what version of SQL?

Cerinity Consulting's picture

DA Version of the sucessfully upgraded databases shows 10.0 SP4 revision 16

SQL server 2005 SP3 Enterprise Edition X64

Going from Version 9.0 SP3 revision 26

Yes these are customer databases

TonySterling's picture

Do you have database Snapshot folders?  I found a couple post where folks had to go into the snapshot folder and update sch file for the offending table; i.e; change SET ANSI_PADDING from ON to OFF in sch file.

 

Cerinity Consulting's picture

Yes have a database snapshots folder but no snapshots listed in it.

Thanks!

 

TonySterling's picture

Hmm, ok then.  Is there any sort of replication going on?  You might need to involve a SQL DBA to assist with that error.

EV_Ajay's picture

Hi,

 

"DELETE failed because the following SET options have incorrect settings: 'ANSI_PADDING'. Verify that SET options are correct for use with indexed views and/or indexes on computed columns and/or filtered indexes and/or query notifications and/or XML data type methods and/or spatial index operations."

Before the above error message appears the upgrade process will appear to hang on running the script AcceleratorPostInstallScriptsV8xx.sql.

Workaround :

Run the script AcceleratorPostInstallScriptsV8xx.sql manually in SQL Management Studio and then retry the upgrade.

  1. The script can be found in the Discovery Accelerator (DA) installation folder on the DA server.
    1. The default location for this folder is 'C:\Program Files (x86)\Enterprise Vault Business Accelerator'.
  2. To run the script manually, use an account with sufficient permissions to modify the DA Customer database contents, such as the Vault Service Account (VSA) 

Note : Before running SQL script on SQL server stop the Enterprise Vault Accelerator Manager Service (EVAMS) on the DA server.

 

Thanks,

Ajay

SOLUTION
Cerinity Consulting's picture

Please note tat on the solution you will receive an error and it will say no rows updated - but did the trick - Thanks!

EV_Ajay's picture

Thanks for sharing the information. Good to see that issue is resolved.

 

Thanks,

Ajay