Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Error while adding NAS drive to Backup Exec : Error=1326 (Help needed !)

Created: 29 Oct 2009 • Updated: 21 May 2010 | 9 comments
magix's picture
This issue has been solved. See solution.

Hello,

I passed my whole day trying to add a NAS to have space for Backup Exec, but it doesn't work !

1. Creating a X: drive on \\nasbackup\backup doesn't work as Backup Exec doesn't want it

2. Then when I try to add \\nasbackup\backup I get this message "Could not create new backup folder. Access denied" and I see in the logs :

Une erreur s'est produite lors du traitement d'une commande B2D.
 Changer: CreatePath() CreateDirectory1 failed (\\NASBACKUP\BACKUP\BackupExec\).  Error=1326

3. And whe I use the assistant I have to add a username and password, I CAN EVEN SEE ALL FOLDERS ON THE NAS, and choose the path, but at the end, Backup Exec says :
Could not create new backup folder. Access denied.

and I see in the logs :

Une erreur s'est produite lors du traitement d'une commande B2D.
 Changer: CreatePath() CreateDirectory1 failed (\\NASBACKUP\BACKUP\BackupExec\).  Error=1326

I would greatly appreciate some help, I'm really becoming insane !
Why isn't it possible to do B2D on NAS ?

Thanks a lot for any help !

Denis

Comments 9 CommentsJump to latest comment

JT_T's picture

I once had one NAS device and allmost same problem. Through Windows explorer authentication worked as it should be, but not from BE 12.5. I had created logon account in BE for NAS device, it didn't work, no error logs anywhere on NAS, so couldn't find exact error.

Had to go easy way, create a folder to NAS, give everyone read/write permissions, only way i got that working with BE. Of course that's not the best practice or nothing like that, but it was the only way with that NAS device.
After testing that backups worked with NAS, i enabled encryption from BE for backups running to NAS, since everyone had access to that backup folder.

Ken Putnam's picture

Sounds like the BackupExec service account does not have rights to the NAS.  If you logon to the media server as the service account, can you map the NAS shares?

Have you added the BackupExec service account to the NAS as an Administrator (or it's equivalent)?

If this response answers your concern, please mark it as a "solution"

magix's picture

Thanks a lot for your help :

Yes I thought about giving rights to the account under which Backup Exec is running, but I didn't find which one it was ?
(I even connected to the NAS with "System" account, but it didn't solve the problem)...
In Windows logs, the error says "Username : N/A"...
Do you know maybe under which user is running Backup Exec ? (Standard installation)
That's maybe the solution if we find out which user it runs under...

For you second question, I cannot do something like that, I must create usernames on the NAS, and then, when connecting from Windows or Backup Exec I have to specify this username and password to connect...

Ken Putnam's picture

Do you know maybe under which user is running Backup Exec ?

Open the Services Management MMC to find out what account the various services are running under.  They should all be the same except the Remote Agent service, which should be running as Local System

(whoever set up BackupExec originally had to specficy the account during installation

If this response answers your concern, please mark it as a "solution"

magix's picture

They all run under ".\Administrateur" except "Backup Exec DLO Maintenance service" and "B.E. Remote agent for Windows" running under "Système Local"...

xaBo's picture

 Please verify with Storage (NAS) Admin rights on folders, even you can see it, probably some permission could miss.

Regards !!
xaBo

JT_T's picture

You can check which account BE uses example from Windows OS's services console. Start, run, services.msc, find Backup Exec services (BE agent runs always with system account, dont change) and check user account.

I think that you cannot grant access rights from NAS to BE account, instead you should create account to NAS, specify needed permission level, and create same account to BE's "Network Logon Accounts". Create new user to BE, make sure that password and username is same on BE and NAS, try to create B2D device to NAS from BE, when it asks for user account, use the one you have created for NAS and BE.

But sometimes that's just doesn't work, as i writed earlier.

There's really no "default account" which BE uses, when installing BE it asks for Domain user account and password to run BE services, if BE server is member of domain, Normally it picks up the user who is logged on to Windows during BE installation, but you can change that.

magix's picture

Well, depending on the Backup Exec services (in services.msc) they are running under "Administrateur" ("Administrator") or "Système Local" ("System" I suppose). I already tried to connect share on both of them.

But now I suceeded in connecting !!! Following all your advices, I tried to add an "Admnistrateur" account to the NAS, and Backup Exec was able to connect !!!

It's really not very logical, it asks you for a "Network Logon Account" but use the default one, instead...

I will try more and tell you if it continues to work or if it was just something temporary...

magix's picture

Hello,

Finally it works, but I admit that I don't understand exactly why it works and how...

What's sure, is that :
1. Bug -> Backup Exec asks which password to use, you can browse the NAS but at the end of the assistant, it fails !
2. Bug -> It doesn't use the specified password, nor the passwords recorded in the "network accounts"
3. So I had to create username "Administrateur" on the NAS
4. And Backup Exec sucessfully connected with this username.
5. As in my config this is the username of the Backup Exec console and the default password in Backup Exec, I supposse BE uses one of the two
6. Conclusion : Backup Exec is bugged when it connects to NAS : it doesn't use the network account specified but something else...

Hope it will help other people searching for a solution ( I saw plenty of forums with this question, but no answer)

Thanks again a lot to everyone that helped, without your help I would still be blocked at this point...

Denis

SOLUTION