Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error while publishing a ServiceDesk Feeder Workflow in SD7.5.1

Created: 17 Jan 2013 • Updated: 26 Aug 2013 | 10 comments
QuietLeni's picture
This issue has been solved. See solution.

Dear All,

Got this error when trying to publish the Incident Management Feeder WorkfloW:

Application Name : LogicBase.ToolCore.exe
Process ID : 3248
Date :17/01/2013 20:30:51
Log Level :Error
Log Category :LogicBase.ExceptionHandler
Machine Name : SD75
Message :
System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it xxx.xxx.xxx.xxx:11434

Server stack trace:
   at System.Net.Sockets.Socket.Connect(IPAddress[] addresses, Int32 port)
   at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(AddressFamily family)
   at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
   at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at LogicBase.Core.Deployment.RemoteDeploymentObject.GetDeployedProperties(String ApplicationName)
   at Symantec.Workflow.Plugins.Deploy.EntMan.EntManDeployAction.GetDeployedProperties(String server, String vdir)
   at Symantec.Workflow.Plugins.Deploy.EntMan.EntManDeployAction.GetServerPropertyItems(AbstractOrchestrationProject project, String server, String vdir)
   at Symantec.Workflow.Plugins.Deploy.EntMan.PropertiesEditorControl.bw_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

This is the first time I have done this on this new SD server.

Anyone know the answer? I like to place solves.

Kindest regards,

 

QuietLeni

 

Comments 10 CommentsJump to latest comment

Will Yalland's picture

I had this aswell

 

you need to set the server to accept remote connections

Load the "Server Extensions Configuration" tool fro mthe task tray tool and click "Allow Remote Conenctions" under the General heading.

 

SOLUTION
reecardo's picture

As above... note that this needs to be done on the machine RECEIVING the workflow.

Lark's picture

When I had this problem I also found I needed to run "Server Extensions Configuration" as an administrator otherwise I had error messages when I tried to save.  This was due to UAC being enabled.

Obvious perhaps but it caused me a delay while I was thinking about it!  I've also found its best to run the Workflow Manager as admin too.

QuietLeni's picture

Thanks to you all for that.

I might ask if this be included in the documentation!

Kindest regards,

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

reecardo's picture

This is definitely in the 7.5 documentation (for Workflow at least, I can't comment on SD)

CNWilliams's picture

This has been documented in the Other things to know section of the Symantec ServiceDesk 7.5 Release Notes.  http://www.symantec.com/docs/DOC5720

Table 1-9                     Things to know

 

Component

Issue

Article link

Improved security controls on the Workflow Server

Symantec has improved security controls on the Workflow Server. The improved security can potentially block the ability to deploy from a local Workflow Designer to a remote Workflow Server. If you cannot  deploy to a remote Workflow Server, change the following setting on the remote Workflow Server before attempting to deploy.

To allow remote connections:

  • On the Workflow Server, right-click on the Task Tray Tool and click Settings.
  • In the Workflow Server section next to Workflow Server Configuration, click the ellipsis.
  • In the General section, check Allow Remote Connections.

Please note that the Symantec security best practice is to revert this setting after you are finished deploying. For more information on Symantec security best practices, see the article ServiceDesk/Workflow General Security Best Practices.

www.symantec.com/docs/DOC6160

Kindest Regards,

CNWilliams

CNWilliams

QuietLeni's picture

reecardo,

OK, thanks. I did not need to do this in WF 7.1 that I can remember. Is this a new security setting for 7.5 that is normally disabled?

Also, I have been searching in SymWise for "documentation 7.5" with the "Workflow Solution" solution and all I get is the Workflow 6.5 documenation.

Kindest regards,

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

reecardo's picture

This is brand new for 7.5 and is off ("secure") by default.

CNWilliams's picture

Workflow 7.5 is not out yet. It will become available with SMP 7.5 once that is out.

ServiceDesk 7.5 is running on an early Workflow 7.5 version.

That being said, the Workflow 7.5 documentation will become available when Workflow 7.5 comes out.

Kindest Regards,

CNWilliams

 

CNWilliams

Lark's picture

I know we're a little off-topic but I found there are two workflow installers available on the SMP server:

C:\Program Files\Altiris\Workflow\Web\Agent\Symantec.Workflow.Setup.exe is dated May 2012

C:\Program Files\Altiris\ServiceDesk\Web\Agent\Symantec.Workflow.Setup.exe is dated October 2012

 

I'm sucessfully using the October version on its own (without SD) and it appears to be 7.5.2000.472 (thats the Workflow Manager version).

By the sound of it we'll see an even newer version once SMP 7.5 comes out. (so maybe mid-year? ;->  )