Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Error while publishing workflow with "Form Start"

Created: 10 Jul 2013 | 1 comment

Hello Everyone,

I've created a workflow and set it to "Form Start". When I run it from the designer it works great, when I publish and run it, I'm getting the following Error:

Log Level :Error
Log Category :LogicBase.Core.Models.Dialog.DialogHttpHandlerBase
Machine Name : ALTWF01
Message :
Error starting/continuing dialog model execution LogicBase.Framework.ObjectDeserializationError: could not deserialize: LogicBase.Core.IOrchestrationComponent[] ---> System.Exception: could not find type Altiris7.TaskComponents.ExecuteDeleteMachineFromADComponent
   at LogicBase.Framework.ArrayTypeConverter.GetObject(ObjectStorageContainer container, ObjectStorageObjectData values, Type arrayType, ObjectStorageErrorHandler errorHandler)
   at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter)
   --- End of inner exception stack trace ---
   at LogicBase.Framework.ObjectReadStream.ReadRelationshipConverter(ObjectStorageValue objValue, Type type, ObjectStorageRelationshipTypeConverter converter)
   at LogicBase.Framework.ObjectReadStream.GetValue[T](String name)
   at LogicBase.Core.Models.AbstractComponentModel.ReadFromStream(ObjectReadStream info)
   at LogicBase.Framework.ObjectStorage.ContainerDeserialize(ObjectStorageContext context, ObjectStorageContainer container)
   at LogicBase.Framework.ObjectStorage.ZipDeserialize(ObjectStorageContext context, Stream stream)
   at LogicBase.Framework.ObjectStorage.Deserialize(FileInfo fromFile)
   at LogicBase.Core.AbstractOrchestrationProject.GetComponentModelPrivate(Model model, Type componentModelType)
   at LogicBase.Core.AbstractOrchestrationProject.GetComponentModel(String name)
   at LogicBase.Core.Models.Workflow.WorkflowExecutionEngine.StartInternalWithProcessIDReturn(IData data, String modelName, IData globalData, String testRunId, TestingScenario testingScenario)
   at LogicBase.Core.Models.Workflow.EmbeddedDialogModel.WorkflowDialogHTTPHandler.StartWorkflow(HttpContext context, DialogSession session, WorkflowDeploymentInfo deploymentInfo)
   at LogicBase.Core.Models.Workflow.EmbeddedDialogModel.WorkflowDialogHTTPHandler.StartDialog(HttpContext context, DialogSession session)
   at LogicBase.Core.Models.Dialog.DialogHttpHandlerBase.System.Web.IHttpHandler.ProcessRequest(HttpContext context)

I repeat: It works without any problems while I run it from the designer.

Thanks in advance,

Dan.

Comments 1 CommentJump to latest comment

reecardo's picture

It seems you have a generated Task DLL on your machine that's fine (has the component you need), but the target machine does not have this updated DLL (the DLL there does NOT have the comp you need)

You can do one of 2 things:

1. Move the generated task DLL manually (usually what I do for sanity's sake). The generated libs live in <install>/Shared/custonlib, and the library you need copied is Symantec.Components.Generated7.Altiris.ASDKTask.dll

2. Optionally, you can go to Project Properties, go to the Libraries tab, and mark Symantec.Components.Generated7.Altiris.ASDKTask.dll as "Publish", then redeploy.