Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Errors 2776 and 2270

Created: 24 Oct 2012 • Updated: 05 Nov 2012 | 7 comments
Rob dos Ramos's picture
This issue has been solved. See solution.

Hi All, 

 

When I restart the services I get the following errors non stop. 

 

 

Event Type: Error
Event Source: Enterprise Vault 
Event Category: Archive Task 
Event ID: 2776
Date: 25/10/2012
Time: 01:38:54
User: N/A
Computer: EVSERVER.avusa.johnnic.dom
Description:
An exception occurred in routine 
 
CArchivingAgent::GetDeletedItemFoldersList 
 
 
For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp?EvtID=2776
Event Type: Error
Event Source: Enterprise Vault 
Event Category: Archive Task 
Event ID: 2776
Date: 25/10/2012
Time: 01:38:54
User: N/A
Computer: EVSERVER
Description:
An exception occurred in routine 
 
CArchivingAgent::GetDeletedItemFoldersList 
 
 
Event Type: Warning
Event Source: Enterprise Vault 
Event Category: Archive Task 
Event ID: 2270
Date: 25/10/2012
Time: 01:38:54
User: N/A
Computer: rbkeva01.avusa.johnnic.dom
Description:
A queued operation exceeded the retry count and has been discarded
 
Exchange Mailbox Archiving Task for EXCHANGE
 
 
 
Processing a user mbx. Legacy mbx 
 
Priority: [True], reporting mode: [False], run now mode: [RN_ARCHIVING, RN_SCPROCESSING (0x3)], continuous mode: [True], msgs to archive per pass: [0], processing disabled and suspended mbxs: [False], rollover log file: [False].
 
Error: [0xC0040AD8], 
Description:  
 
 
Running 9.0.3
Exchange 2007
 
Thanks

Comments 7 CommentsJump to latest comment

Jeff Shotton's picture

Hi Rob,

Do you see lines like this in dtrace:

CAgentTask::Initialise - Failed to open privileged MAPI session - aborting agent startup, error [c0040ad8]

This sounds very much like a MAPI permissions thing. Have you checked to see if you can create a profile, that the system account is on the right server, you can open other users mailboxes as the VSA etc etc...i.e all the standard stuff?

Does the task eventually fail?

What does deployment scanner say about permissions?

Regards,

Jeff

Jeff Shotton

Principal Consultant

Adept-tec Ltd

Website: here

Rob dos Ramos's picture

No Mapi errors

 

MAPICommon::GetFixed_PR_FOLDER_PATHNAME() - The source folder is the root of the information store, returning an empty string

Processing MSMQ message body (ActivateObject) failed with [0xc00408e2]. The retry count will be incremented, and the message reposted to the end of the queue.

} An error that we don't specifically recognise has occurred, [0xc0040ad8], so we'll just increment this messages retry count.
2402 11:50:08.283  [584] (ArchiveTask) <3028> EV:L {AgentMessageDispenser::ActivateObject} (Exit) Status: [The dispenser was asked to repost the message to be retried later      (0xc00408e2)]
2403 11:50:08.283  [584] (ArchiveTask) <3028> EV:M {AgentMessageDispenser::ProcessNextMessage:#1250} It took [3.723858] seconds to process the [MsgID_ArchiveMailboxExImp2 (78)] MSMQ message body (ActivateObject). Processing the message [failed].

Regards,

Rob

 

Rob dos Ramos's picture

No Issues with Deployment scanner

Have done all the basics

Tasks do not fail at all

Regards,

Rob

 

Rob dos Ramos's picture

Tried running office-kb2512788-fullfile-x86-glb but it states it is not the right version. 

 

Server is running outlook 2007 SP3

Regards,

Rob

 

Rob dos Ramos's picture

 

CFaultInjector::LoadConfig looking for fault config in C:\Program Files (x86)\Enterprise Vault\ArchiveTask.EXE.fault.
3048 13:28:39.694 [4988] (ArchiveTask) <3900> EV:H {CFaultInjector::Configure:#124} _com_error exception: [The system cannot find the file specified.  (0x80070002)]
3049 13:28:39.694 [4988] (ArchiveTask) <3900> EV:H {CFaultInjector::Configure} (Exit) Status: [The system cannot find the file specified.  (0x80070002)]

Regards,

Rob

 

Jeff Shotton's picture

Hi Rob,

That hotfix is for Outlook 2007 sp2 - Outlook 2007 sp3 already has the increased MAPI limits.

From what I can tell this:

Processing MSMQ message body (ActivateObject) failed with [0xc00408e2]. The retry count will be incremented, and the message reposted to the end of the queue

Is just a 'we had a failure so are re-posting the message to the back of MSMQ' message -its in the following example where the issue was simply backup mode set:

https://www-secure.symantec.com/connect/blogs/odd-...

 

Get a FULL dtrace from when the task is starting up...so

1) stop the archiving task

2) enable dtrace for archivingtask

3) log it to a file

4) start the archving task and the trace run for a minute after starting the archiving task.

5) stop the trace and post it here.

 

Regards,

Jeff

 

Jeff Shotton

Principal Consultant

Adept-tec Ltd

Website: here

Rob dos Ramos's picture

Hi All,

 

Upgraded the system from 9.0.3 to 9.0.4 and all the errors disappeared. 

 

Thanks for all the help.

 

Rob

Regards,

Rob

 

SOLUTION