Video Screencast Help

EV 8.0.4 - Mailbox Archiving messages where recipient was BBC'd

Created: 18 Oct 2012 • Updated: 05 Nov 2012 | 13 comments
This issue has been solved. See solution.

Hi,

We want to archive Leavers mailboxes in Ev 8.0.4, so we have zero day achiving policy, added all message classes to archive everything, however some users have items in their inbox with no To: or CC: field, maybe these mails were sent BBC'd to a DL or set of recepients, 

Why EV is not archiving those messages? Is there any settings we need to apply? 

Many Thanks

Comments 13 CommentsJump to latest comment

TonySterling's picture

Those actually sound like drafts to me.  On the Advanced tab of the Archive Policy did you enable the setting to archive Drafts?

JesusWept3's picture

maybe appointments that havent expired or are recurring?

 

ia01's picture

These are IPM.Note - mails sent to BCC users. Not Appointments.

We also have that settings to archive unexpired appointments.

Thanks

JesusWept3's picture

ok well dtrace archivetask, do a run now and we'll have a look why its not processing the item
it could be that the item has the Do Not Archive flag set on it, it could be that its in a folder controlled by EVPM and that the filter is stopping the mail policy from taking effect.
It could be that the user was able to set their own rules on the folder through the client and that filter is blocking the main policy.
 

ia01's picture

Hmmm just trying Archive Leaver tool from Quadrotech-IT and I think there are some problem with some items, logs below

 

 

2012-10-18T15:19:45|TRACE|P:8016|T:9|EVWrapper|Inserting Item: R:\ALTmp\00000000A475A82CFE51594EAE2400440A74918C070031A1D62D52BBE84C8D2D13A91C382E8F00000029B7D60000084BA484D6AD5940872BF638D89E8E2500BBCCF2F57D0000.msg
2012-10-18T15:19:45|TRACE|P:8016|T:9|EVWrapper|Path is \Sent Items
2012-10-18T15:19:45|ERROR|P:8016|T:9|EVWrapper|Error ingesting Item R:\ALTmp\00000000A475A82CFE51594EAE2400440A74918C070031A1D62D52BBE84C8D2D13A91C382E8F00000029B7D60000084BA484D6AD5940872BF638D89E8E2500BBCCF2F57D0000.msg.
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040306): An internal failure occurred. Internal Error: 'Failed to get custom properties.      [0xc004710f]'.
   at KVS.EnterpriseVault.Interop.IItem.Insert()
   at QUADROtech.ArchiveLeavers.EVWrapper.ImportItem(String archiveLocation, String messageFileName)
2012-10-18T15:19:45|ERROR|P:8016|T:9|MailboxProcessor|Problem archiving item.
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040306): An internal failure occurred. Internal Error: 'Failed to get custom properties.      [0xc004710f]'.
   at KVS.EnterpriseVault.Interop.IItem.Insert()
   at QUADROtech.ArchiveLeavers.EVWrapper.ImportItem(String archiveLocation, String messageFileName)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ArchiveItem(String entryId, String location)
2012-10-18T15:19:45|ERROR|P:8016|T:9|MailboxProcessor|Problem processing item.
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040306): An internal failure occurred. Internal Error: 'Failed to get custom properties.      [0xc004710f]'.
   at KVS.EnterpriseVault.Interop.IItem.Insert()
   at QUADROtech.ArchiveLeavers.EVWrapper.ImportItem(String archiveLocation, String messageFileName)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ArchiveItem(String entryId, String location)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ProcessItem(RDOMail item, String folderPath)
2012-10-18T15:19:45|ERROR|P:8016|T:9|MailboxProcessor|Problem processing folder.
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040306): An internal failure occurred. Internal Error: 'Failed to get custom properties.      [0xc004710f]'.
   at KVS.EnterpriseVault.Interop.IItem.Insert()
   at QUADROtech.ArchiveLeavers.EVWrapper.ImportItem(String archiveLocation, String messageFileName)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ArchiveItem(String entryId, String location)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ProcessItem(RDOMail item, String folderPath)
   at QUADROtech.ArchiveLeavers.MailboxProcessor.ProcessFolderImpl(String folderId)
2012-10-18T15:19:45|TRACE|P:8016|T:3|MAPIWrapper|MAPI Stack disposed successfully
 
Rob.Wilcox's picture

Talk to us over .... >>> http://www.quadrotech-it.com/support/ticket/ <<< here :)

ia01's picture

To be honest Archive Leavers tools is little flakey, mailboxes with corrupt items or too many folder structure it will fail, then manual archive run from VAC sometimes clears the items, sometime you run Archive Leaver many times and eventually it crears up the leavers mailbox :-)

Error codes are somewhat generic and sometimes difficuly to understand why its failing, such as when it says Catastrophic failure ;-D

ia01's picture

Well I looked at that link http://www.quadrotech-it.com/support/ticket/

But no option to select "Archive Leavers" there are other products to choose from.

TonySterling's picture

Not sure if this was still an issue but there as a hotfix for EV 8 sp 4 for the error you are seeing:

 

Hotfix for Enterprise Vault (EV) 8.0 SP4. During a Move Archive Job, or Archiving, an error occurs when a problem item returns "Parameter incorrect" error and/or "Failed to get custom properties. [0xc004710f]", during the copy phase of a move, or during archival.

Article:TECH136409  |  Created: 2010-01-08  |  Updated: 2011-04-15  |  Article URL http://www.symantec.com/docs/TECH136409

 

SOLUTION
ia01's picture

Thanks Tony, we have that hotfix installed, multiple retry of archive run and Archive Leavers tool eventually cleared all items in all leavers mailbox, some mailboxes had few corrupt item and we had to remove them manually so that archive run completes.