Video Screencast Help

EV 9.0.2; Enterprise Vault OWA Extensions; Event-ID: 0: unhandled exception

Created: 25 Aug 2011 • Updated: 18 Nov 2011 | 6 comments
Kai Schröer's picture
This issue has been solved. See solution.

Hi!

Our customer get this error several times per day:

---
Log Name:      Application
Source:        Enterprise Vault OWA Extensions
Date:          23.08.2011 13:08:07
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      %name%
Description:
An unhandled exception was caught:
 
System.NullReferenceException: Object reference not set to an instance of an object.
   at Symantec.EnterpriseVault.Owa.ResponseFilters.Premium.Folder.ProcessSP1()
   at Symantec.EnterpriseVault.Owa.ResponseFilters.ResponseFilterBase.Close()
---

The Error occur sporadic and unregular.

I've found further Events from this source with ID 0 in the KB, but the description doesn't fit.

For the same time-frame we couldn't find any errors in OWA-Logs or IIS-Logs.

Does anybody knows something about this Event and the Description?

Environment:
EV 9.0.2
Exchange 2003 SP2
Windows Server 2003 SP2

Thanks in advance!

Kai

Comments 6 CommentsJump to latest comment

JesusWept3's picture

Seen this before, it means that it's expecting a response and to have data available but doesn't have any
Saw this within m own environment when there was an issue with EWS crashing, and if EWS is down then EV's OWA extensions will fail to work

Are there an other errors on the CAS other thanthis that might point to the issue?
You may need to call symc support if you can't find anything obvious

Kai Schröer's picture

Sry for the late response. I couldn't found any "real" issues on the Exch.-Servers. I want to open a case at symantec. But I will keep the thread inform.

PMCS.helpLine Software Gruppe
www.pmcs.de
Twitter: https://twitter.com/PMCS_EV

Kai Schröer's picture

Symantec told us that this error should fixed with EV 9.0.3

"It is a problem with the NullException being returned when we request a PreviewMessageClass."

It is rolled up into this TN http://www.symantec.com/docs/TECH160437

Lets see...

PMCS.helpLine Software Gruppe
www.pmcs.de
Twitter: https://twitter.com/PMCS_EV

SOLUTION
Muhammad Nazakat's picture

Event ID 0 - Error: "An unhandled exception was caught" occurs on an Exchange Client Access Server (CAS) Server after installing Enterprise Vault (EV) Outlook Web Access (OWA) Extensions.

http://www.symantec.com/docs/TECH63996

Regards,

Muhammad.

Kai Schröer's picture

Hi Muhammad,

unfortunately this solution is too easy.

Of course we've checked this article before.

The Error 0 has different descriptions and unfortunately not just one error-source.

But thanks for the input.

:-)

PMCS.helpLine Software Gruppe
www.pmcs.de
Twitter: https://twitter.com/PMCS_EV