Video Screencast Help

EV and NTFS compression

Created: 28 Oct 2013 | 7 comments
Alex Zn's picture

Hi!

I use FSA to archive Windows 2008 R2 File Server, the problem is when i perfrorm retrival from EV archive there is no compression attribute, that was before, so my files become uncompressed and use more space. Is there a way how could i preserv compression on files during archivation, or set them back after retrival?

PS I even have tried to set "compress..." on a folder level, result was the same.

Operating Systems:

Comments 7 CommentsJump to latest comment

TonySterling's picture

So do you mean you are restoring the archive back to the file server or do you mean you are just viewing the files?

If you are just viewing the files they will be turned back into place holders after a period of time.

Alex Zn's picture

I am just viewing files.

TonySterling's picture

Ok then, after a period of time the file will turn back into a placeholder.  At the very latest it will be on the next run of the FSA task.

Alex Zn's picture

But if the file was modified, then it will be uncompressed and will consume more space than should. My question was about is it possible to preserve compression? Probably i did not found this option!?

Nate.D's picture

I dont think what it sounds like you are asking, is possible. Vault 'rehydrates' the data when an archived file is accessed. If its modified, then the file no longer fits your archiving criteria and would not be subject to archival until conditions are met again (time, etc.) I think thats just the way it works. I dont think it could keep itself compressed, and be opened/interacted/modified all while compressed. If it worked like that we would keep everything compressed all the time!

If I was helpful in solving your issue please mark my post with a thumbs up or a solution!  Have a great day :)

GabeV's picture

Hello Alex,

I think that you might need to check the attributes of the files once the placeholders are recalled. I know that NTFS doesn't allow you to compress and encrypt a file at the same time. It might be something related to NTFS. Perhaps, there is another attribute applied by Windows that is not allowing the compress attribute to be applied. Have you tried to restore the archived file from Archive Explorer to see if the file is restored and compressed?

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

Alex Zn's picture

Yes i have tried to restore file from Archive Explorer, in this case compression attribute is preserved. So seeams it is not preserved in case of recall.