Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EV archive Journaling Index not getting updated

Created: 20 Jul 2012 • Updated: 08 Dec 2012 | 14 comments
This issue has been solved. See solution.

Hi Guys,

Enviroment: Windows 2003 Ent + EV 9.0.2 + O2K7 Sp3 + 3 Journal Task

I am having a weired issue here Mails are getting Journaled in real time without any issues, but they are not getting indexed.

last time it happened i had restarted the Indexing service and the index updated started. But now when i am trying to do the same is wont update and it shows me around 5 million items to be indexed.

Also checked if index is failed but there is no index marked failed or updating. One thing i noticed in task manager is it just shows me indexbroker.exe and no indexserver.exe. Hence after restarting the index service it shows for sometime and then again it will disapper.

I have captured a dtrace for 5 min for indexing attaching the same.

Please provide me your inputs on the same.

Comments 14 CommentsJump to latest comment

RahulG's picture

1st make sure Indexes are not in backup mode.

LCT's picture

it doesn't look like your indexes are in backup mode

598 14:34:53.058  [7200] (IndexServer) <7676> EV:M CSynchronizerThread::IsIndexLocationInBackupMode IndexVolume=[13B97869BFE82564CAE9418CB71D7C57B1110000journalingMUM/Volume:915 (MUMBAI2011)], InBackupMode=[False] (hr=Success  (0))
599 14:34:53.058  [7200] (IndexServer) <7676> EV:L CSynchronizerThread::IsBackupModeEventSet Index:[13B97869BFE82564CAE9418CB71D7C57B1110000journalingMUM/Volume:915 (MUMBAI2011)], BackupModeEventSet:[No] (hr = Success  (0))

Is this EV server doing EV journal archive only? or is it doing other archiving too? From your description it may be a memory corruption hence the indexserver.exe keeps dying. Have you tried rebooting this EV server? I had a similar with other processes a while a go on a windows 2003 server. Anything in the event logs?

I will continue with the logs and see what i can find in there. 

LCT's picture

oh...are the index locations still accessible and disk space is OK? just a quick thought.

LCT's picture

i can see the following:

CIndexAccessBase::GetIndexServer HRESULT exception caught (hr=Indexing Service is busy.      (0x80041c86))

8279 14:35:08.604  [7176] (IndexServer) <1104> EV:M CSynchronizerThread::ThreadRoutine 13B97869BFE82564CAE9418CB71D7C57B1110000journalingMUM/Volume:916 (MUMBAI2011) (hr=Operation aborted  (0x80004004)) 

Other than the above and no event logs I can't realy suggest anyting else other what i have already said above.

Nathan Clark 2's picture

MaxIndexServers (DWORD) 10 [0xa]

why is this 10? default is 30.

LCT's picture

Good spot Nathan, I did noticed that a few lines before this line

CIndexAccessBase::GetIndexServer HRESULT exception caught (hr=Indexing Service is busy.      (0x80041c86))

but didn't think much of it, perhaps this was changed and caused this ev server to become overloaded?

Cdee's picture

Server reboots daily morning and also the MaxIndexservers was set 10 from before itself not changes was done as such.
Also i checked if index is in backup mode but it was not in backup mode.

memory utliziation is not so consumed i have 8 GB and normally it shows 2 Gb used overall.

I will try to modify the MaxIndexServers thread from 10 to 30 and see if this helps

Thanks all for your feedback on this.

Sr Messaging Engg.

Cdee's picture

Trying the registry didnt help opened a case with Symantec support but still unable to figure out whats going on it..

Infact support told me to remove the registry key.

Any other things to check.

Sr Messaging Engg.

LCT's picture

Hi Cdee,

Did you get anywhere with Tech Support regarding this issue?

I'd be very interested to know what caused this issue.

JesusWept3's picture

I could be wrong, but this would be my guess:

{CStore::IsOpenVault}|Requested: 13B97869BFE82564CAE9418CB71D7C57B1110000journalingMUM Current:  Open: False

SOLUTION
Kazuyuki Ichikawa's picture

Please teach how this matter was restored.
I am troubled with the same problem, too.

Michael Bilsborough's picture

It could be that the Vault is in a Vault Store that is in backup mode?

Mike

Kazuyuki Ichikawa's picture

Hi,Mike.

I confirmed that there is not index in backup mode, but am unconfirmed whether Vault Store is Backup mode.
But I seem to be able to be busy to a journal from Exchange. . In having done that the update date of the file change. .