Video Screencast Help

EV archiving only sent items

Created: 19 Jan 2013 • Updated: 20 Jan 2013 | 10 comments
This issue has been solved. See solution.


One of the mailboxes in our enviorment is not getting archived by EV. Only the sent items of that mailbox is archived, although the criteria fits a lot of other emails.

We're are running EV 9 and Exchange 2007.

Attached is the report for the said mailbox.

Comments 10 CommentsJump to latest comment

Rob.Wilcox's picture

So it says, I think, 78 archivable items.

It doesn't say where they are located.

The best thing to do is setup dtrace of the archiving task, and do a run now .. just archiving, and just for this user.  Then look through that for references to things like 'iseligible' or search for the subject of items that you think should be archived, and aren't.

JesusWept3's picture

If its just the sent items it typically means an EVPM script has been run to see things like \inbox to DoNotArchive Or also set them with rules different than the mailbox policy

The other thing could be that the items have been restored/exported from the archive and its waiting for inactive period to end

Ie you have an item that was received on 12/01/2012 and set it to archive after one month, on 01/01/2013 it archived, on 01/02/2013 it got restored, the item will not be archived again until 02/02/2013

AbdullahMS's picture

I created a new policy just for this mailbox, and set it to simply archive all items older than 6 months, just to simplify the troubleshooting but it still have the same problem.

The emails were never archived in order to restore them, so its not that for sure.

JesusWept3's picture

So it's either EVPM or something similar
Like rob said, get a DTrace of the archiving task

AbdullahMS's picture

I ran a DTrace and got the result; most of the 74 items were not archived because the inactivity period did not expire yet. The problem is, the mailbox have more than 1000 archivable items, but EV isn't even acknowledging that.

AbdullahMS's picture

I found this line in the dtrace log:

EFP - Folder Policy Settings for [Inbox]|  Filter Type = Not archiving this folder (do not archive)|  Archive Settings Locked = FALSE|  Override Locks = FALSE|  Delete Original = FALSE|  Create Shortcut = FALSE|  Archive unread items = FALSE|  Archiving based on : Age and Quota|  Age and Quota:|    Age Based Period = 999 Years|    Quota Percent Free = 0|  Not using Size Priority Settings

JesusWept3's picture

Which is one of three things
1. EVPM used to set to DoNotArchive
2. You right clicked \imbox in outlook and went to the Enterprise Vault tab and changed the policies for that folder to not archive

OR what might be more likely
3. It's an Exchange Managed Folder and your exchange archiving policy is set to not archive managed folders

You could try zapping and reenabling your mailbox for archiving, this would resolve issues 1 & 2

More about EV and Managed Folders can be read here

AbdullahMS's picture

1. How can I verify that EVPM is not to set to DoNotArchive?

2. I don't see the EV tab in Outlook in order to change the policies.

3. The policy used for this mailbox is used for many other mailboxes, which have the same configuration in Exchange, so I don't think this is the case.

I will look into the links you provided and report back.


AbdullahMS's picture

Zapping worked, the archivable items jumped to more than 2000!

Thank you very much, Alex.