Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EV via OWA gets worse for Mac users

Created: 10 Feb 2011

At our site we have a lot of Mac users. Now while EV access by OWA using IE has always been pretty good, none of the Mac browsers (which always used the Light version of OWA) have been brilliant. But it was usable. What happened was then when you double clicked on an archived item in the message list, it retrieved and opened the full message, in a form which was no different as any other (unarchived) message. You could forward it, reply to it etc. In fact, you could not even tell it has been archived apart perhaps from a slower retreival. Of course there were no EV buttons, no way to search the archive etc. Most users found this satisfactory if incomplete.

That was the situation with OWA2003 and EV8. We have now started migrating to Excahnge 2010 ( and upgraded to EV 9). I actually hoped for an improvement as the Mac browsers (e.g. Safari and Firefox) can now get the full version of EV. OWA2010 is greatly improved on a Mac. But access to archived messages has got a lot worse.

Now when you double click on an archived message, you only get the shortcut stub returned (the same as you see in the preview window). Yes the user can still get to the original items, by clicking on the "View the original item" link in the stub. But this then requires a seperate logon, and only gives the "view" version of the message - no reply or forward buttons. If the user wants to reply or forward they first have to do a restore - a rather clumsy way to do something which was previously so simple.

I know that OWA access on a Mac to EV archived items has never been supported by Symantec, but it did used to work. Does anyone know of a workaround for this situation which can recreate the previous behaviour? Maybe not, as the whole access model had to change with 2010, but i thought it was worth asking before I get lynched.

Elliot