Video Screencast Help

EV OWA problems, question about Installing OWA extensions

Created: 21 Jun 2013 • Updated: 24 Jun 2013 | 4 comments
This issue has been solved. See solution.


I keep getting the error "The archived item is currently unavailable" in OWA when opening a shortcut, but the icons display fine, and the previews work OK. This is EV 10.0.3 and Exchange 2010 SP3. I went back and added the anonymous account and ran the wsf script, and uninstalled the OWA add-in and reinstalled it, but it is still not working. I looked at the installing and configuring manual, and found the following on page 82, but it is not clear if this should be done on the Exchange CAS server or the EV server. This is a very simple lab setup with a single EV server, single Exchange server, and a single SQL server for EV.


The following are required for accessing Enterprise Vault from OWA clients:
Enterprise Vault OWA 2010 Extensions require Exchange Server 2010 SP1 or
The following Role Services must be installed for the Web Server (IIS):
IIS Management Scripts and Tools
IP and Domain Restrictions
In addition, the option IPv4 Address and Domain Restrictions in Feature
Delegation must be set to Read/Write. To find this option, open Internet
Information Services (IIS) Manager and click the server object in the navigation
pane. Open Feature Delegation and ensure that IPv4 Address and Domain
Restrictions is included in the listed options.

Operating Systems:

Comments 4 CommentsJump to latest comment

AndrewB's picture

those steps after "The following Role Services must be installed for the Web Server (IIS):" are for the EV servers

the OWA extensions get installed on your CAS servers

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner |

Arjun Shelke's picture

Do you see the EV toolbar buttons such as Archive Explorer and Search in left pane bottom?

If yes then I believe OWA extensions are installed properly but the communication between your CAS and EV is not as expected. When user double clicks on archived item in OWA, the restoreo2k.asp is called on EV Server. You can see this call in IIS logs of EV Server.

This retrieval depends upon following things on EV Server:

1. Data Access Account: Open Vault Admin console under vault service account credentials. Right click on "Directory on <EVServerNameRunningDirectoryService>" and select properties, then Data Access Account tab. The account which you used to run the OWAusers.wsf script must be configured here. (i.e. Anon user)

2. Shopping basket permissions: Open Vault Admin console under vault service account credentials. Expand EVSite >> EV Servers >> EVServerName >> Services >> EV Shopping Service. Right click on Shopping service and select properties. Copy the shopping location path and open in windows explorer. Check the NTFS permissions (security tab) of this folder and make Anon user account has Full rights.

3. IP and Domain restrictions: As per your findings, you should first install this from IIS role services. If it was not installed before. If you install this role service, then I would suggest re-running the OWAUsers.wsf script after deleting the EVAnon virtual directory. (make sure you run the command propmt under administrator) Once you re-run the script, open IIS manager and check IP restrictions section of EVAnon VD to see if CAS Server IP address has been allowed. If not you can manually allow the IP by adding it.

4. You will need to restart EV Admin service and synchronize mailboxes in order for changes to take effect.

5. You might need to reset IIS if this doesnot help.

I hope this helps...

rnt123's picture

Oddly, the EVanon virtual directory was not created after running the owauser.wsf script. I reran it, rebooted, and it was there, and all OWA functionality worked! Thanks AndrewB!

AndrewB's picture


Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner |