Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EV OWA Toolbars do not display

Created: 09 May 2013 • Updated: 21 Jun 2013 | 6 comments
This issue has been solved. See solution.

Hi,

I am having issues with accessing archived items via OWA. This used to work up until the past few days. The icons show up in OWA, but the toolbar no longer does. When I click on an archived item I get this message...

403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.
 
Thanks
Operating Systems:

Comments 6 CommentsJump to latest comment

JesusWept3's picture

try re-running the EVOwaUser.wsf script on your EV Server to properly set up the /EVAnon directory
Also you would have to run this if you change the IP Addresses of the exchange servers since it works on a white list, where it only allows certain IP addresses connect to that particular virtual directory

So when you move exchange servers, change ip addresses of exchange servers or add new exchange servers, you either need to add the IP Addresses to ExchangeServers.txt and run the evowauser.wsf script, or manually add the new ip addresses to the /evanon virtual directory

The same would need to be done if you migrated from one EV Server to another.

That being said, you should still see the EV buttons, typically if you can't see the EV toolbars and options, it means that it can't read the hidden message in the users mailbox, which more often than not is an issue with contacting EWS to read the properties

It could also be that maybe you changed from HTTP to HTTPS on the exchange side of things and OWA is configured to go to http only, it could be that an SSL certificate has expired and EV OWA extension is just getting an SSL error and can't load the page etc

SOLUTION
Always_Something's picture

Look at your registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Install

Look at the InstallPath 'D:\Program Files\Enterprise Vault' key to ensure you do not have an extra back slash after it.

Like 'D:\Program Files\Enterprise Vault\'

After several sessions of troubleshooting OWA, we found a little known issue that may arise with Enterprise Vault installed on Windows Server 2003 that effects OWA. When running the OWA configuration script to setup OWA on EV, part of the script sets up the \WebApp directory in the EV install folder, and adds this to the Enterprise Vault Install path in the Registry. So, from the EVAnon Properties, the Folder Path is set to C:\Program Files\Enterprise Vault\\WebApp, which is in error. Or D:\ drive or install drive of the OWA app.

Here is the Tech Note with the solution we used to fix this issue. The problem was we had this for an older version of EV and the symptoms were not exactly spelled out the same as what we were experiencing. The EV Technician I worked with has put this in to have this Tech Note updated to include the problem and symptoms from this case.

You will need to restart the EV Task Controller service if you perform this step.

http://www.symantec.com/docs/TECH66294

Hope this helps. It was my exact issue.

Advisor's picture

I hope your will get resolved by referring to above given steps..if not can you post the version of EV and exchange server along with the IIS logs from EV and CAS/FE depending upon the version of exch.

viktorrj's picture

Thanks for your reply

I´ll do it, all this steps, just wait a few days

Thanks

viktorrj's picture

I forgot to say:

I´m using Exchange ent 2007 and EV 10.0.2

Rob.Wilcox's picture

Did you manage to get this sorted out viktorrj?